Home   Manual

Working with an avogadro branch


#1

Avogadro team:

I am new to Avogadro and large project development on windows. I just started working with Geoff Htuchison on minimizes and have ee batteling configuration issues all the way. After some difficulties I finally got Avogadro to build on my computer.

My current problem started when I downloaded a branch that Geoff added to Avogadro. I have downloaded the code from GitHub and it has been added to a subdirectory. However, now I can’t get the build process to work.

I first made a openchemistry-ghutchis directory

I then when to cmake-gui where I entered the openchemistry source code directory and openchemistry-ghutchis as the build directory.

When I his configure I got the following error message

CMake Error at C:/Program Files/CMake/share/cmake-3.12/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find Eigen3 (missing: EIGEN3_INCLUDE_DIR EIGEN3_VERSION_OK)
(Required is at least version “2.91.0”)
Call Stack (most recent call first):
C:/Program Files/CMake/share/cmake-3.12/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
cmake/FindEigen3.cmake:76 (find_package_handle_standard_args)
avogadro/core/CMakeLists.txt:1 (find_package)

Note that I get the same error message if I run “cmake …/openchemistry” from the command prompt.

I appreciate your help.

Dave

David Wertz

[email protected]

(856) 581-9075


#2

I’m not sure why the Windows build isn’t downloading Eigen for you, although I have a student who reported a similar problem tonight.

I’d try setting (either with the CMake GUI or cmake on the command-prompt):

cmake -DEIGEN3_INCLUDE_DIR=/usr/local/include/eigen3 ../openchemistry

From the GUI, you’d need to set the EIGEN3_INCLUDE_DIR variable.

If that doesn’t help, I’ll ping Patrick and Marcus to reply…