Where to find pythons scripts/plugins

Hello,
I am trying to view the plugins using drag and drop but the plugins are just being installed. After installation I am not able to find them anywhere in the avogadro window …neither in the build menu nor in the extensions menu.
for example




I even tried to rebuild avogadro and the openchemistry modules repeatedly using the docs and associated github repos…but am not getting from where to get access to those plugins.
Could anyone please help
Thanks

At the moment, the plugins won’t reload - you will have to restart Avogadro for them to be called.

Hii,
I also restarted avogadro but the plugins arent visible anywhere.

Secondly, some of the icons also aren’t visible after rebuilding.
For example:
Look at this:


the navigation, selection etc tools arent visible
Do you have any other alternative?

I didnt face any errors as such while building but how to ensure that it has been built correctly?
Can you please help
Thanks

I even tried to change the python environments but its not being changed …neither the plugins are being displayed in the built section. Is anyone else encountering similar issue?

Avogadro looks in a set path depending on your OS. For Windows, it would be C:/Users/USER/AppData/Local/Avogadro

https://two.avogadro.cc/develop/scripts/install.html

You mentioned rebuilding, but it looks like you haven’t updated avogadroapp - the tool icons now use SVG and you need the latest commits to the app.

If you start Avogadro from the command-line, you will see where it’s looking for plugin scripts and any messages about Python errors, etc.

That would be helpful for figuring out what’s happening.

Hello,
In my case no such path is being created… instead the plugins are being saved in roaming folder ie:
C:\Users\dhruv\AppData\Roaming\OpenChemistry\Avogadro

yes, okay this worked…just for clarity,If any repository gets updated do one has to rebuild avogadro or just git pull, update submodule is sufficient?

you are asking to run the binaries from within the prefix directory in the build tree right?
cd C:\Users\dhruv\Desktop\OpenChemistry2\openchemistry-build\prefix\bin>avogadro2
Like this right …on the command line??..but just avogadro window is being opened without any errors.

Okay, that’s kind of surprising, but it should still look in that directory. What do you have in that path?

I don’t use Windows - was nothing printed to the command line window?

So, the folder contains separate folders for commands, formatscripts, data, i18n and input generators

No just avogadro window opened up

Is there any way to check in which directory is it looking into?
Thanks

Any windows user here or anybody encountering similar problem wrt the python plugins??

It should be printing a bunch of paths onto the console, e.g.

"Checking for commands scripts in path /Users/ghutchis/Library/Application Support/OpenChemistry/Avogadro/commands"
"Checking for commands scripts in path /Library/Application Support/OpenChemistry/Avogadro/commands"
"Checking for commands scripts in path /Users/ghutchis/Devel/build/openchemistry/prefix/Avogadro2.app/Contents/Resources/commands"
"Checking for commands scripts in path /Users/ghutchis/Devel/build/openchemistry/prefix/Avogadro2.app/Contents/MacOS/../lib/avogadro2/scripts/commands"
"Checking for inputGenerators scripts in path /Users/ghutchis/Library/Application Support/OpenChemistry/Avogadro/inputGenerators"
"Checking for inputGenerators scripts in path /Library/Application Support/OpenChemistry/Avogadro/inputGenerators"
"Checking for inputGenerators scripts in path /Users/ghutchis/Devel/build/openchemistry/prefix/Avogadro2.app/Contents/Resources/inputGenerators"
"Checking for inputGenerators scripts in path /Users/ghutchis/Devel/build/openchemistry/prefix/Avogadro2.app/Contents/MacOS/../lib/avogadro2/scripts/inputGenerators"
…

Looks like this is a known problem on Windows. Try redirecting the output, e.g.

Having the same problem here on Win10.
I am trying to install a plugin for two days now.

avogadro2 (stable and nightly build from today) isn’t showing any text on the console. Redirection produces an empty file.

Extensions → Python Settings finds 3 installations but does not keep my choice.
Plugin Download list is empty.
Drag and drop into the Avogadro2 window does nothing.
Tried copying the plugin into the mentioned directories and restarting Avogadro, but still loads nothing.

Nightly should be creating an avogadro2.log file in Documents on Windows.

Windows has had a persistent problem with HTTPS connections because it’s been a pain to get OpenSSL packaged. (For whatever reason, Qt libraries do not include OpenSSL DLL, nor do they indicate dependencies.)

For that particular case, I’ve been working on packaging: Make sure to grab both libcrypto and libssl on Windows by ghutchis · Pull Request #464 · OpenChemistry/avogadroapp · GitHub

Drag-and-drop and copying into directories should work, but without seeing the console messages (now in avogadro2.log) it’s hard to know what the bug is.

From avogadrolibs/avogadro/qtplugins/downloaderwidget.cpp, it looks like the plugin downloader is using AppDataLocation.

While in avogadrolibs/avogadro/qtgui/scriptloader.cpp it looks like AppLocalDataLocation is being used:

  // List of directories to check.
  /// @todo Custom script locations
  QStringList dirs;
  QMap<QString, QString> scriptList;

  // add the default paths
  QStringList stdPaths =
    QStandardPaths::standardLocations(QStandardPaths::AppLocalDataLocation);
  foreach (const QString& dirStr, stdPaths) {
    QString path = dirStr + '/' + type;
    dirs << path; // we'll check if these exist below
  }

  dirs << QCoreApplication::applicationDirPath() + "/../" +
            QtGui::Utilities::libraryDirectory() + "/avogadro2/scripts/" + type;

Which I guess means that on Windows, extensions are being installed to %APPDATA%\roaming but looked for in %APPDATA%\local?

On the other hand, drag-and-drop seems to be handled by avogadroapp/avogadro/mainwindow.cpp and the destination is AppLocalDataLocation.

Can this have anything to do with the problem?

Okay, this adjusts the plugin downloader location using AppLocalDataLocation

OK, I got the plugin to work via manual install.

Problem: The …/AppData/Local/Avogadro directory was created, so I put the plugin there.
Solution: According to the log, this directory is never checked. The plugin has to be put in …/Local/OpenChemistry/Avogadro/command.

This is a bit of an unexpected behaviour.

  1. …/AppData/Local/Avogadro/ was there in the first place, but …/Local/OpenChemistry/Avogadro had to be created by myself.
  2. The documentation and the forum never mentions subfolders for command, energy, etc. I expected, that avogadro just searches all subdirectories for the plugin.json file and deduces the script type from there.

The script still does not work as expected, but at least it loads and is integrated into the menu structure.

Ah, well that is the correct behaviour. I’m currently working on updating the documentation, so I’ll fix the mistake and make it clearer about the subdirectories.

I guess it would probably be a good idea to create the subfolders on launch if they don’t exist yet, to make it more obvious where scripts should be saved if doing it manually.

Yes!

I am having a very difficult time getting the Input Generators. I’ve historically had this issue with most releases on Windows, Ubuntu, and Ubuntu (WSL2).

This is after downloading the input generator plugin

pluginsdownloaded

This did not work for me for input generators, but I’m glad you said something. Might be helpful to keep in mind for different versions

You don’t have input generators because Avogadro cannot find Python on your system.

If you have Python installed, go to Extensions ⇒ Python Settings… and select the path to python3.exe (or whichever).

1 Like