Testers Needed for Mac M1 packages

I’ve been building on my M1-based MacBook Air and think I can distribute signed releases.

Is there anyone who’d like to test a build?

  • Do you see any “unknown developer” dialogs?
    • These builds should be properly signed / notarized … but it’s my computer’s certificate so I want to make sure they work on other Macs :slight_smile:
  • Do you find other errors after launching / running?
    • They should be bundled properly for an M1 machine, but again, it helps to know if it works on other people’s Macs…



Here’s the beta M1 package I can assure you that it’s signed and passed Apple’s notarization. It’s also the version I’m using on my laptop. Otherwise, it doesn’t have much testing yet, so help is appreciated!

[ Please use a download from the GitHub releases ]

Hi, just downloaded the dmg, worked great! I’m still getting the ‘Error interpreting Open Babel output.’ output when trying to optimise geometry, but that was also a problem for me with 1.94 and 1.95

Did any error message pop up about unknown developer, etc.?
(I’m trying to ensure the signature / notarization is solved.)

The Open Babel error is different - the “hardened runtime” required to sign apps requires a specific entitlement to load Open Babel’s plugins. Pretty sure I have that one solved now too.

That sounds great! I only got the normal warning (downloaded from the internet) which I could immediately press “open”

1 Like

Hi, I tried installing the software on Macbook Air M1 and got the following error message
“Avogadro2” can’t be opened because Apple cannot check it for malicious software.

Did you download the M1 link above (from Dropbox) or the M1 release

Because with 1.96 and 1.97 releases, the M1 versions are signed and notarized.

Thank you prof. for the reply. Yes, I downloaded from the above link and just tried again to install. It is showing the same “Avogadro2” can’t be opened because Apple cannot check it for malicious software.

I just downloaded the dmg file from the below link and it got installed. Thank you.

That one is not arm64 version though.

this one gives the “unknown developer” dialog

Huh. I’ll have to look into that. Thanks.

To double-check, the 1.97 x64 (non-arm64) release does not show the “unknown developer” but the M1 release does?

1 Like

Yes, that’s correct.