Some atoms in a big molecule won't be shown when rotating

Dear all,
I’d like to use Avogadro to show Cartesian coordinates through build – Cartesian editor. But I always get the confusing display problem. When I want to display a relatively big molecule and rotate it, some atoms would be missing, as shown in the figures. I found the molecule will be correctly shown when I choose view – Projection — then any of the two options.

I wonder that it is possible to correctly display without doing the view-projection thing ? Thank you!

Environment Information

Avogadro version:1.2.0
Operating system and version:windows 10


I think you need to zoom out. There can be some clipping on the “front” side close to the screen, (i.e., the program won’t let you see atoms that would project in front of the imaginary screen boundary) but you’re seeing clipping on the “far” side too.

This can be done with the scroll wheel.

Thank you for your reply and sorry for this late. But zooming out doesn’t solve the problem.


the zooming figure: