Running with Windows 11

I’ve installed the latest version of Avogadro software. I’m using 64 bit laptop with Windows 11 Home, version 21H2. I cant even open the application, if I try to open the app its showing like “MSVCP100.dll missing” and “MSVCR100.ddl missing” and “0*c000007b error”. I tried all the possible ways from the internet, but still I’m unable to use the software. I’ve used Avogadro before in Windows 7, it is an excellent software. But now I need this very badly. Hope you will help me with this. Thank You!!!

Can you please be more specific about the version you’re using and “all the possible ways from the internet” that you’ve tried?

Avogadro version: [Avogadro-1.2.0n-win32.exe]. I’ve searched the solutions for that missing dll files {“MSVCP100.dll missing” and “MSVCR100.ddl missing” and “0*c000007b error”} and downloaded that files, also reinstalled the visual c++ app and also the DirectX end-user runtime application. Still I cant use the Avogadro software. So please help me

can you please reply me

Is running a Windows Subsystem for Linux (WSL) an option for you (see instructions for a setup) or installing a secondary operation system (like e.g., Linux xubuntu, or Debian)? Because then, you could install a much more recent version of Avogadro (e.g., 1.95 for Debian (tracker), or Ubuntu Jammy (tracker)) which already aims to version 2.0 in preparation.

Version 1.2 you (apparently) got hold is from a branch no longer in development. Speculation: perhaps an update of the files sourceforge distributes got forgotten.

I cant understand it. Please explain it.

Reformulated: If you need a more recent version of Avogadro to work with, seek access to Linux, which may be installed in parallel to an already existing OS like Windows, or Mac. Xubuntu is one form of Linux easier to start with, than other. If you don’t want a permanent installation, or are not permitted to do so, run it from a thumb drive (e.g., instructions).

Once running, install avogadro from the command line

sudo apt-get install avogadro

which should install you this program as an additional entry among the programs in about education.

Don’t hesitate to ask for some initial assistance by your colleagues at school (e.g., in physical chemistry/quantum chemistry) if it is your first contact with Linux.

Hi,

I have the same issue as Arif, and for me running a WSL is not a solution.
Avogadro 2 is working fine though but I need features that are not implemented yet that are available with Avogadro.

I’m on a windows 11 system and before that I use it successfully on a windows 10 before.
Is there any other solution?

Thank in advance for the help.

What particular features do you need? We’re currently working to finish up Avo2 and could certainly prioritize some things for 1.96.

Hi,
Sorry for the late reply.
What I’m looking for is an optimization Tool in order to have the 3D geometry of a molecule.
I can’t find it yet un Avo2

thanks a lot

We do not currently have the tool (and it will instead be a mode / command).

You can, however, currently optimize the geometry as usual using Open Babel.

Extensions => Open Babel => Optimize Geometry

The shortcut should be Control - Alt - O (or Command-Option O on Mac).

Thank you for the info. A mode/command would be awesome as well.

I will have a look right away via the OpenBabel method.

Anyway, Avogadro is a really nice tool, thanks a lot for this great work!

I will let you know if have any issues