Home   Manual

Problems running Avogadro on Windows - DLL missing

Hi,

I’ve got a new Windows machine and I just installed Avogadro on it.
When I try to run it, I receive multiple alert boxes saying that “The code execution cannot proceed because MSVCP100.dll was not found. Reinstalling the program may fix this problem.”, and the same for “MSVCR100.dll”.

Googling for those filenames, I’ve found instructions to install “Microsoft Visual C++ 2010 Redistributable Package”, which would include those files.
I’ve tried installing the 2010 (the version that showed up when I searched for those filenames) version. It didn’t work. Then I’ve tried the latest version, 2017. It didn’t work. I tried reinstalling Avogadro after that, still doesn’t work.

I’ve confirmed that those required files are present in my C:\Windows\System32 folder, but the error messages still appear.
Now I’m clueless on what to do next. Should I try copying those files somewhere under the folder where I’ve installed Avogadro? Any insights?

Thanks in advance,

Marcelo

I think the most useful information - which isn’t in your message:

What version of Windows?
What version of Avogadro?

Installing both the x86 and x64 packages of Microsoft Visual C++ 2010 Redistributable solves the problem.

2 Likes

I believe the new 64-bit builds of Avo2 (e.g. 1.94) should also fix this problem.

Thank you, I had the same issue and this fixed it.

1 Like