Problem with the path of openbabale library

Hi everyone,

I want to install Avogadro on my linux64 desktop. Openbabel-2.2.3 is
currently installed om my home directory. I used the following cmake
commend:

cmake …/
-DOPENBABEL2_INCLUDE_DIR=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/
include/openbabel-2.0/
-DOPENBABEL2_LIBRARIES=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/li
b/

And I received the following error:

– checking for module ‘openbabel-2.0>=2.2.2’

– package ‘openbabel-2.0>=2.2.2’ not found

CMake Error at cmake/modules/FindOpenBabel2.cmake:81 (message):

Could NOT find OpenBabel 2.2 or later

Call Stack (most recent call first):

CMakeLists.txt:131 (find_package)

– Configuring incomplete, errors occurred!

Cmake and openbabel are installed correctly and the only problem may be
difinition of path. I appreciate let me know how I could solve this issue.

Thanks

Somaye

Hi Somaye,

On Fri, Mar 11, 2011 at 3:46 PM, badieyan@users.sourceforge.net wrote:

cmake …/
-DOPENBABEL2_INCLUDE_DIR=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/include/openbabel-2.0/
-DOPENBABEL2_LIBRARIES=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/lib/

Try:

cmake …/ -DOPENBABEL2_INCLUDE_DIR=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/include/openbabel-2.0/
-DOPENBABEL2_LIBRARIES=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/lib/libopenbabel.so

(note the “libopenbabel.so” at the end of the library specification).

Dave

Hi Somaye,

Assuming that the directories and paths are correct, you can try to
override the version check by adding "-DOPENBABEL2_VERSION_MET=true"
to the cmake command.

Dave

On Sat, Mar 12, 2011 at 4:26 PM, badieyan@users.sourceforge.net wrote:

Thanks you David for your prompt reply. I followed your suggested path:

cmake …/
-DOPENBABEL2_INCLUDE_DIR=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/include/openbabel-2.0/
-DOPENBABEL2_LIBRARIES=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/lib/libopenbabel.so

But the same error message:

– checking for module ‘openbabel-2.0>=2.2.2’

– package ‘openbabel-2.0>=2.2.2’ not found

CMake Error at cmake/modules/FindOpenBabel2.cmake:81 (message):

Could NOT find OpenBabel 2.2 or later

Call Stack (most recent call first):

CMakeLists.txt:131 (find_package)

– Configuring incomplete, errors occurred!

I have even checked the other options in lib directory (libopenbabel.so,
libopenbabel.so.3, libopenbabel.so.3.0.3, pkgconfig/openbabel-2.0.pc, …) but
for all I have received the same error. For more details I have also
attached the CMakeCache.txt (the output of cmake).

Thanks for your help.

Somaye


Hi Somaye,

On Fri, Mar 11, 2011 at 3:46 PM, badieyan@users.sourceforge.net wrote:

cmake …/

-DOPENBABEL2_INCLUDE_DIR=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/include/openbabel-2.0/

-DOPENBABEL2_LIBRARIES=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/lib/

Try:

cmake …/
-DOPENBABEL2_INCLUDE_DIR=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/include/openbabel-2.0/
-DOPENBABEL2_LIBRARIES=/home/badieyan/openbabel/openbabel-2.2.3/usr/local/lib/libopenbabel.so

(note the “libopenbabel.so” at the end of the library specification).

Dave