"plugin downloader" feature issue

Hi all,

I have an issue with the plugin downloader. I needed to use the Gaussian generator for an assignment, and after installing Avogadro version: 1.93 (I think), on my ubuntu 20.04 pc, I went looking for it.
I found, under extensions, the plugin downloader.
I went to the menu and clicked to download the inputgenerators package. It told me it had downloaded the .zip and unpacked it and where. So far, so good I thought.
However, when I closed the plugin downloader and went to extensions again, nothing seemed to have changed. So I opened the downloader again, and there I saw exactly what I had seen the previous time.
I then checked to see if the files had actually been downloaded, and they had indeed, in the same place where the downloader told me. (/home/nathan/.local/share/OpenChemistry/Avogadro/inputGenerators/)

At this point I went to check the downloader page again, and read around on this forum and the manual website. To no avail. The only thing I did find which I thought might be relevant, was the following text in the downloader:
"These scripts need to be installed in a location where the Avogadro 2

application can find them, for example the “Plugin Downloader” feature."

Having read this, I checked my directory for such a file or folder. It was not anywhere I could find.

I went back to this site and read that my version of python might be the culprit. So I updated my version of Python3(.8) to python3.9 and 3.10 just in case.
This did not yield any new results, so I tried to see if I needed to reboot.

Finally, this did not change anything either, so here we are.

I really hope one of you can help me, and also I hope I have not missed a post on this site, and would thus be wasting your time.

The 1.93 release has a number of notable bugs. The current release is 1.95.1 - I believe there is already an Ubuntu package for it as part of the 22.04 LTS release: https://launchpad.net/ubuntu/+source/avogadro

We will likely be releasing 1.96 sometime this week. There are also nightly AppImage installs:
https://nightly.link/OpenChemistry/avogadrolibs/workflows/build_cmake/master/Avogadro2.AppImage

And there are Flatpak builds as well:

Thanks for replying so quickly. I really appreciate it.

I’ll try to download the new version. (although I don’t know if I can, because my version of ubuntu is still 20.04)

I don’t actually know how to install it though. I installed the last one through the terminal I think, because it was in the release of mu distro.
I had tried but failed to install the 1.2.0 version before that, but I couldn’t find the install file I needed to do the installation.

Both Flatpak and AppImage are really easy to install.

I can also see that there’s a “bleeding edge” PPA for 20.04 that includes Avogadro 1.95.1.

1 Like

Thanks, I managed to install and execute Avogadro1.95.1 with the applmage file and I also installed the PPA (I thought at first that I couldn’t run the applmage without terminal :sweat_smile:) \

Now everything works except that when I try to draw my molecule, the system keeps crashing and and it tells me the following:
afbeelding

anyway, it keeps doing this so I think I must have made a mistake with the installation.
I don’t mind though, I’ll replace the version I have now soon anyway when the new version comes out.

(edit: I forgot to mention: it didn’t do this before the update)

What I did notice that might interest you is that the automatic hydrogen adjustment is often wrong. I got four hydrogens on an end-C (which would make the carbon pentavalent) and none on a tertiary sp3 carbon multiple times…

If you’re using the AppImage, please try the recent 1.96 release:

As to the hydrogen adjustments … there’s a known bug - it seems to be a race condition (i.e., it depends on how fast you are vs. your computer, among other things).