OpenGL problem?

I have a very weird behaviour with Avogadro. When I start it up from
the command line, Avogadro opens the regular way, displaying a black
canvas for an empty “view”. However, after a second or so, the part of
the screen that gives the 3D canvas disappears and instead I see the
background, or whatever was there before I opened avogadro. Clicking on
the 3D canvas (or where it is supposed to be) gives my back the 3D
canvas. But as soon as my mouse leaves the canvas, I get the
background again. This clearly is very inconvenient.

Now I’m not sure if this really is an Avogadro problem -I have no
problems on another machine- but maybe somebody can shed some light on
this.
By the way, I/m using OpenSuse 11.1 with a radeon RV790 graphics card.

Regards,
Bertwim

On Wednesday 20 January 2010 17:43:03 B.W.H. van Beest wrote:

I have a very weird behaviour with Avogadro. When I start it up from
the command line, Avogadro opens the regular way, displaying a black
canvas for an empty “view”. However, after a second or so, the part of
the screen that gives the 3D canvas disappears and instead I see the
background, or whatever was there before I opened avogadro. Clicking on
the 3D canvas (or where it is supposed to be) gives my back the 3D
canvas. But as soon as my mouse leaves the canvas, I get the
background again. This clearly is very inconvenient.

Now I’m not sure if this really is an Avogadro problem -I have no
problems on another machine- but maybe somebody can shed some light on
this.
By the way, I/m using OpenSuse 11.1 with a radeon RV790 graphics card.

This sounds like a commonly observed bug with Linux compositing desktop
managers, the video driver and OpenGL applications. You can likely fix the
issue by disabling compositing/desktop effects. I have only recently been able
to enable this using Arch Linux, 2.6.32 kernel and latest proprietary nVidia
drivers.

Hope that helps.

Marcus

Thanks for your response. My computer has an ATI radeon card. I’m quite
sure I use the latest drivers.
Assuming (or hoping) that 3D graphics supports is better for nvidea card
(my previous computer had nvidea), I recently swapped the ATI for an
nvidea card. To my surprise, astonishment and disappointment, I didn’t
get any 3D picture at all! So I swapped the card back.
Hoping for better times…

Bertwim

Marcus D. Hanwell wrote:

On Wednesday 20 January 2010 17:43:03 B.W.H. van Beest wrote:

I have a very weird behaviour with Avogadro. When I start it up from
the command line, Avogadro opens the regular way, displaying a black
canvas for an empty “view”. However, after a second or so, the part of
the screen that gives the 3D canvas disappears and instead I see the
background, or whatever was there before I opened avogadro. Clicking on
the 3D canvas (or where it is supposed to be) gives my back the 3D
canvas. But as soon as my mouse leaves the canvas, I get the
background again. This clearly is very inconvenient.

Now I’m not sure if this really is an Avogadro problem -I have no
problems on another machine- but maybe somebody can shed some light on
this.
By the way, I/m using OpenSuse 11.1 with a radeon RV790 graphics card.

This sounds like a commonly observed bug with Linux compositing desktop
managers, the video driver and OpenGL applications. You can likely fix the
issue by disabling compositing/desktop effects. I have only recently been able
to enable this using Arch Linux, 2.6.32 kernel and latest proprietary nVidia
drivers.

Hope that helps.

Marcus

Hi,

It took a while before I understood what you meant with the Linux
"compositing desktop managers",
and “disabling compositing /desktop effects”. I was looking for an
option of the window manager.

But then I found the setting

Option “Composite” “on”

in my xorg.conf file. When I changed on -> off

the problem disappeared! I also noticed that what inde KDE desktop is
called “shading” (collapsing a window into its title bar only (and back)
now works much faster. Thanks a lot.

Bertwim

Marcus D. Hanwell wrote:

On Wednesday 20 January 2010 17:43:03 B.W.H. van Beest wrote:

I have a very weird behaviour with Avogadro. When I start it up from
the command line, Avogadro opens the regular way, displaying a black
canvas for an empty “view”. However, after a second or so, the part of
the screen that gives the 3D canvas disappears and instead I see the
background, or whatever was there before I opened avogadro. Clicking on
the 3D canvas (or where it is supposed to be) gives my back the 3D
canvas. But as soon as my mouse leaves the canvas, I get the
background again. This clearly is very inconvenient.

Now I’m not sure if this really is an Avogadro problem -I have no
problems on another machine- but maybe somebody can shed some light on
this.
By the way, I/m using OpenSuse 11.1 with a radeon RV790 graphics card.

This sounds like a commonly observed bug with Linux compositing desktop
managers, the video driver and OpenGL applications. You can likely fix the
issue by disabling compositing/desktop effects. I have only recently been able
to enable this using Arch Linux, 2.6.32 kernel and latest proprietary nVidia
drivers.

Hope that helps.

Marcus