Numbers display in Arabic

Hi Everyone,
I just installed Avogadro 1.2.0 on Windows 10 and there is something really weird. All the numbers in the tools, extensions and even atom labels are in Arabic. The rest (letters) are normal latin letters like I am used to.
I’d appreciate any help to fix this!

Environment Information

Avogadro version: 1.2.0
Operating system and version: Windows 10

Expected Behavior

modern numbers 0,1,2,3,…

Actual Behavior

arabic numbers ٠,١,٢,٣,…

Avogadro 1.2.0 is of a branch no longer actively maintained. Instead – and if your workflow permits – use the executables of the branch leading to Avogadro2 as available on this landing page. (For some additional functionality, you might need OpenBabel and Python, see an earlier answer.)

Check if the newer version of the program equally displays the numbers as Arabic numbers (0, 1, 2, … are only of the Latin script, which unrelated to «modern» or «old»). In case you replicate the observation, report back (including the locale the operating system of the computer used). Equally worth to check is if (perhaps accidentally) an adjustment of the default font of the operating system can resolve the use of different scripts.

I suspect you have Arabic set as your locale / native language?

In general, Avogadro (all versions) try to respect your system settings. Avogadro 1.97 and later do have a menu option to set the localization if you don’t want this.

OK… that was my problem. Funny that I never noticed it anywhere else… must have been accidentally set just recently.
Thank you!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.