Installing Avogadro 1.2.0

Dear Users and developers,
I have been unable to install Avogadro 1.2.0 on Ubuntu 20.04, and some features in Avogadro 1.9.3 are not proper such as addition of hydrogens in ligands and the same features seem to be appropriate in Avogadro 1.2.0.
The problem I am facing right now is that I have been unable to install Avogadro 1.2.0 on Ubuntu 20.04? Is there any way I could install that bypassing some requirements?

You do not specify the pathway leading to the result that (old 1.2.0) Avogadro did not install when compiled from source or using a .deb. (I think the distribution of portable AppImages for Linux is a recent addition after dropping the development on Avogadro 1.2.0).

The Grimme group (university of Bonn, Germany) offers a container to work with old Avogadro (post by Geoffrey in the forum, and the GitHub repository). Do your attempts already include testing this option?

If this doesn’t work well enough, there still is the option to retain/install a spare instance of e.g., Xubuntu 18.04LTS (Bionic Beaver) with old .deb packaged Avogadro side by side to the LTS of 20.04 (Focal Fossa)/contemporary 22.04 (Jammy Jellyfish) on the same computer. A multi-boot installation can be set up to either a) let both Linuxes access the same home partition, or b) that there is a small logical partition just to shuttle the relevant data back and forth.

Hi @Thomas I tried compiling it(old 1.2.0) from source resulting in incompatilibity with Qt4 libraries.
And have also tried the Docker image provided by Grimme group which does installs but ends up in an OpenGL error while running the Docker image as mentioned in an issue in their repo https://github.com/grimme-lab/avogadro-container/issues/3. Moreover I installed the mesa-utilis package with sudo apt-get install mesa-utils to overcome the OpenGL issue yet, it is not working yet.

Well this seems to be too much of a task!

For me and so far, using a docker image was out of question and not needed because the multi-boot installation was/is just fine for me. So perhaps the Grimme group may help.

As option 2bis, it equally is possible to “burn” a live image of Ubuntu on a USB thumb-drive (a tutorial), similar to a portable office which doesn’t require much additional weight in the back pack and for a non-permanent environment into which one may load/install (old) Avogadro “as usual” via synaptic. (This requires internet connection.)
Then either a) the drives of the OS normally used on the computer are visible (if not encrypted) and ready for read and write, or b) I bypass the (Avogadro) data from/to a second, simultaneously used thumb drive intended only to carry data for a total of two thumb drives. (This data drive actually contains an old .deb of Avogadro, too.) For this task, two memory sticks (4 GB each) provide more than sufficient capacity.

1 Like

I was also trying to use the Docker container by Grimme, but I always get the same error:

avogadro: cannot connect to X server :1

I also believe the dual boot is a bit too much for just using one single program. Instead you can try to install a virtual machine (Virtual Box is free), and install there an Ubuntu 18.04 version to intsall Avogadro in your virtual machine.

P.S: If anyone knows how to solve the problem of the docker and the X server, I would be much appreciated!

For completness, i follow the instructions:

export XAUTH=/tmp/.docker.xauth
export XSOCK=/tmp/.X11-unix
docker run -it --rm \
       --volume=$XSOCK:$XSOCK:rw \
       --volume=$XAUTH:$XAUTH:rw \
       --env="XAUTHORITY=${XAUTH}" \
       --env="DISPLAY" \
       --env="QT_X11_NO_MITSHM=1" \
       ghcr.io/awvwgk/avogadro

Are you using the Docker container on Linux and running X?

If so, you probably need to set xhost + before running Docker or similarly invoking Xauthority (Can you run GUI applications in a Linux Docker container? - Stack Overflow)

X11 is designed to allow remote connections, but obviously there are security precautions for that. (Wow, this brings back really old memories)

What seems to be missing in your invocation is something like this (copied from the Stack Overflow answer):
xauth nlist :0 | sed -e 's/^..../ffff/' | xauth -f $XAUTH nmerge -

Yes, I am running Linux and X (no Wayland). I tried everything you said in the past, and never worked, but thanks to this I kept researching a little bit more and found a solution!!

If I run the docker with --net=host it works! I found the solution here, so the commands that led to a working docker are:

export XAUTH=/tmp/.docker.xauth
export XSOCK=/tmp/.X11-unix
docker run -it --net=host --rm \
       --volume=$XSOCK:$XSOCK:rw \
       --volume=$XAUTH:$XAUTH:rw \
       --env="XAUTHORITY=${XAUTH}" \
       --env="DISPLAY" \
       --env="QT_X11_NO_MITSHM=1" \
       ghcr.io/awvwgk/avogadro
2 Likes

@pallavsen007 Does this also solve your OpenGL problem? Looks like your problem is with the drivers of your graphic card. Are you using NVIDIA?

If not, I can’t help with that, but in that case I believe your best option would be to run a virtual machine.

@basillicus If the additional flag --net=host is a reliable approach to use Avogadro in the sandbox by the Grimme lab, consider adding a note to the Facing problems with the docker image @pallavsen007 filed earlier on GitHub.

I just noticed he already is using this --net=host flag. This will not solve his problem I’m afraid, as it looks like it is more related to graphic card drivers.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.