Incorrect version number in built version

Hi, I noticed that in the version of Avogadro I have compiled myself, the version number is incorrectly still showing 1.98.1.

I imagine I just haven’t updated the part of the source code that specifies it. The submodule approach described in the docs (where you use git clone --recursive didn’t work for me, so the individual components are all cloned separately and I sometimes forget to update parts.

Can you tell me where the version number is taken from in the source code? CMakeLists.txt has the correct version in both avogadroapp and avogadrolibs, so I guess it can’t be that.

It tracks two versions - the app and library version, since those could in principle be out of sync. So in the about dialog, it shows both.

The library version is kept in avogadrolibs/avogadro/core/version.h in your build directory.

The app version is kept in avogadroapp/avogadro/avogadroappconfig.h in your build directory.

In principle, those should be regenerated when CMake files are updated, but if you haven’t updated the avogadroapp directory beyond the 1.99 release, it will indicate an older version number.

So this is the thing, both those files have the wrong version number. But even after making sure avogadrolibs and avogadroapp are completely up-to-date, it’s still wrong. Even after completely deleting the build, remaking the directory and rebuilding it is still incorrect. I tried make clean too, and also tried making a new build in a different directory, but to no avail.

So these should pick up on the change in the various CMakeLists.txt files?

Uh, that’s weird. You tried a completely new build directory and the CMakeLists.txt have the up-to-date version number?


Precisely… very odd.