Impossible to read frequency calculation fro G16 output


I am using Avogadro version 1.97.0.
In my directory (/home/nastasia/.local/share/OpenChemistry/Avogadro), I have installed the Generators and Avogadro-cclib plugins. After loading my file, I have selected the "OpenBabel: Generic Output" file format.
My molecule is correctly loaded, but when I try to view the vibrational modes under “Analysis → Vibrational Modes,” it appears impossible to display them.
I am feeling a bit confused about how to resolve this.
Any help would be greatly appreciated.

Best regards,

mp2_avdz_freq_tight.out (158.6 KB)

As by Geoffrey’s note by September (link), the current development version of Avogadro 1.97 does not include it.

A bypass can be to revert to old Avogadro. If you have an instance of Xubuntu 18.04 LTS / Bionic Beaver, than old Avogadro 1.2.0 still is available in the repositories (no longer covered by the default package search, however the package is listed here). In Linux Debian, the package is available as old-old stable in branch 10/buster (entry) though its dependencies (vs a contemporary instance of Debian 12/bookworm) might require some additional adjustments.
Else, test the entry on sourceforge – based by the date of the last in 2017, the files may be old enough for the time travel.


Thank you for your response. I apologize I did not see Geoffrey’s note in September.
Unfortunately, I’m using Ubuntu 22.04. I managed to install Qt 4.8.7, CMake 2.8.9, and Open Babel 2.4.1. The installation process of Avogadro (sourceforge) went smoothly without any issues. However, when I navigate to /home/nastasia/Downloads/avogadro-1.2.0/build/bin and run ./avogadro, I encounter the following error:

QPixmap: Must construct a QApplication before a QPaintDevice Aborted (core dumped)

To be honest, I’ve never come across an issue like this before, so I’m feeling quite perplexed. Could this problem be related to having Avogadro 2 installed as well? Or Ubuntu 22.04 ?

Any assistance you can provide would be greatly appreciated

PS: I had to modify a file according to this thread Avogadro 1.2 - Build fails in Fedora 24 (x64) · Issue #836 · cryos/avogadro · GitHub but I do not think so that this is the issue here

Well, it relates to Avogadro 1.2 and the related code being no longer supported.

To me, it looks like you’re having a minor issue with Avogadro 1.97 (i.e., your Gaussian file isn’t reading the vibrational modes) and you’ve tried to build an older version of Avogadro… which isn’t going to read your G16 output either.

I’d suggest two approaches:

  • Try a nightly AppImage of 1.98 which in theory should have the G16 bug fixed in Open Babel along with a pile of other fixes
  • Install cclib into your Python environment (e.g., pip install cclib or conda install cclib) and then install the avogadro-cclib extension in Avogadro (Extensions → Download Plugins)

I use the cclib interface regularly, and 1.98 will use it automatically when available.


Thank you for your answer. I have clean my computer from previous Avogadro to avoid problem.
I have downloaded your AppImage and for some reason nothing is shown on my screen.
However, I have cclib already installed since dpkg -l | grep cclib returns:
ii cclib 1.6.2-2 all Parsers and algorithms for computational chemistry
ii python3-cclib 1.6.2-2 all Parsers and algorithms for computational chemistry (Python3 module)
Because this is an Appimage which I launch doing ./Avogadro2-x86_64.AppImage
I do not know how to set up the extensions directly in my terminal. Do you know how to solve this please ?

Okay, I’m not quite sure why the AppImage isn’t showing extensions - probably networking. (The list of extensions and then the packages themselves are on GitHub)

But if you’re using the AppImage, you should be able to read in the file - the bug in reading Gaussian 16 frequencies should be fixed.

If not, use the 1.97 release. Just install the avogadro-cclib parser.


I feel a bit confused with your answer because although I have a running Avogadro 1.97, it can not print the vibrational frequencies.
When I am loading my files using cclib, the vibrational Modes under Analysis menu is now available but Avogadro2 crashed while trying to use it
In fact, if I started to install previous version of Avogadro is to be able to see it
Did I misunderstood something ?

Can you please send me the file? Certainly Avogadro shouldn’t crash with the cclib interface.

I’m not sure what you mean. Avogadro 1.2 does not support Gaussian 16.


Here the different files that I used with Avogadro 1.97.
test.tar (37.9 KB)

I can attest that it works okay from here in 1.98-development.

I do not know what is happening with cclib import, but it is possible that there is a bug with cclib-1.6.2 perhaps. ccget --list test.log with v1.8 gives me:



You are correct. It was an issue with cclib 1.6. Therefore, I have installed cclib 1.8.
When I run ccget --list test.log, it returns the same output as you mentioned. However, when I run Avogadro, I encounter this error.

Initially, I thought it might be due to the language settings, which I changed to American English, but the error persists.

When I run Python and execute cclib.file, it returns the expected output: /usr/local/lib/python3.10/dist-packages/cclib/

Is there something I might have missed during the installation process?


I believe I have made some progress. It appears that using the extension plugins to download cclib is not working for some reason. Consequently, I chose to git clone the official repository directly in order to have it. Now, it seems that I can open fchk files and view my IR spectra.
However, when I attempt to open the .log file using cclib, I encounter this error:

Error reading CJSON file.

Is this an expected behavior? Does it mean I need to use OpenBabel to view my molecules with my g16 output files and cclib for fchk?

Best regards.

Avogadro 1.9x have internal code for reading fchk files, although I don’t think it reads vibrational modes. (Your file is the first fchk that I’ve seen with normal mode information.)

There seems to be a bug with the avogadro-cclib interface. It looks like cclib is doing the right thing, so I’ll look into the problem. (There’s a warning from cclib because the H-Cl is linear which might be the issue.)

Yep. If you try the latest avogadro-cclib plugin, it ignores the warning and seems to work great now.

Thanks for the bug report - this will clearly help a lot of other Gaussian users.

1 Like


After doing a git pull for avogadro-cclib plugin, I was able to load my linear molecule and view it in Avogadro2.
Regarding the bug with my mp2_avdz_freq_tight.out file, I have opened a ticket on the cclib github repository. I will keep you informed of any developments (if needed) or issues related to this output after discussing it on the cclib thread.

Thank you very much for your time and assistance.

Yes, I’m also going to look into reading vibrations from the fchk files. Seems like G16 includes that now!

Just back from a session in old Xubuntu 18.04 LTS (64 bit) where I installed old Avogadro 1.2.0 .exe for Windows 32bit with the support of (again) old wine (version 3.0 from the repositories) to mimic Windows 8. (Avogadro1 as provided by Xubuntu’s repositories was intentionally removed for this test.)

There was no problem to read mp2_avdz_freq_tight.out of the two-molecule computation (IR spectrum, vibrations, dipole moment), nor the test.log (one IR vibration, dipole moment, MOs).

test_old_avogadro.tar (3.2 MB)

I think back then likely some libraries were added manually to wine a contemporary installation (perhaps by now around a GB) now might include by default.


My previous old computer was running Ubuntu 18.04 LTS (64 bits) as well. With that computer, I had no problems running Avogadro from SourceForge. However, I recently switched to a new computer with Ubuntu 22.04.

For some reason, certain packages needed to build Avogadro (from SourceForge) are not very stable on Ubuntu 22.04, which could explain why I encountered this core dump issue. Unfortunately, this software is no longer maintained, and Ubuntu 22.04 doesn’t provide a solution for the missing packages required to build qt4.

As a result, I prefer to stick with Avogadro2 and wait for a response on my cclib thread. I believe the solution will be valuable for all Avogadro2 users, as well as cclib users.

Thank you for your time and assistance.