HBond display can't change colours

Hi all,

Just installed Avogadro 1.1.1 app and lib version on Mac yosemite 10.10.1.

Unless I am missing something very obvious I can’t change hydrogen bonds to a different color. They always remain yellow even when I select custom color. I am able to change hydrogen bond width so I know the software can act on them.

I have tried enabling and disabling hydrogen bonds between changing colours, I have even tried the other “Colour by” options with no change.

Any help would be appreciated. Thanks
Anthony

Dr Anthony Nash
Department of Chemistry
University College London

Nash, Anthony <a.nash@…> writes:

Hi all,

Just installed Avogadro 1.1.1 app and lib version on Mac yosemite 10.10.1.

Unless I am missing something very obvious I can’t change hydrogen bonds
to a different color. They always
remain yellow even when I select custom color. I am able to change
hydrogen bond width so I know the software
can act on them.

I have tried enabling and disabling hydrogen bonds between changing
colours, I have even tried the other
"Colour by" options with no change.

Any help would be appreciated. Thanks
Anthony

Dr Anthony Nash
Department of Chemistry
University College London

I notice that hbondengine.c has yellow hard coded. I would try and change it
myself (I am) but I am usually awful at cmake beyond the most basic
installations (and I am currently failing). Is this software still being
supported? I noticed that this bug has been discovered before (in an earlier
version).

Thanks
Anthony

Has this problem been fixed? I can see this thread is old, but i’m currently running through the same problem.

edit: spelling

No, not at the moment. I’ve been concentrating on getting the h-bond rendering working with Avogadro v2. I’ll mark that people want an option to set the color.