Fwd: Avogadro's Issues

Begin forwarded message:

From: XZ xz@rambler.ru
Date: August 19, 2007 9:07:41 PM EDT
Subject: Avogadro’s Issues
Reply-To: XZ xz@rambler.ru

Good Day, Geoff.

Hope, I mail to the proper address ))

I have a problem with Avogadro: see attached screenshot. When
running on Windows XP, it show a mysterious rectangles on the
junctions instead of the helpful information… The same issue with a
"Measurent Tool", which info not displayed correctly… What to do?

Also I intend to write a plugin for Avogadro, which will calculate
some parameters… Could you give me an example & a code of working
plugin for Avogadro? Could you explain how to build it and link it
up with Avogadro? Thanks for your time.


Best Regards,
Valerian mailto:xz@rambler.ru

On Monday 20 August 2007 03:37:29 Geoffrey Hutchison wrote:

Begin forwarded message:

Good Day, Geoff.

Hope, I mail to the proper address ))

I have a problem with Avogadro: see attached screenshot. When
running on Windows XP, it show a mysterious rectangles on the
junctions instead of the helpful information… The same issue with a
"Measurent Tool", which info not displayed correctly… What to do?

Also I intend to write a plugin for Avogadro, which will calculate
some parameters… Could you give me an example & a code of working
plugin for Avogadro? Could you explain how to build it and link it
up with Avogadro? Thanks for your time.

Looking at the screenshot provided it would appear there are some problems
with OpenGL on the system. The spheres representing the atoms also don’t
appear to have any colour applied to them for some reason although the
cylinders do.

Currently we draw text using the default font whatever that is - it could be
that the default font doesn’t provide the glyphs we need, but it looks more
like an OpenGL issue to me. First off I would see if updating the graphics
drivers helps at all. Benoit may have more ideas but he is not around at the
moment.

Thanks,

Marcus