Conformational search (number of conformers = 0 )

Hi all,
Im currently running conformational search using avogadro. I can see from the past that avogadro searching where rings are involved may get complicated (which is fine). Also, once the program deems that there are no rotatable bond (even if there is, and past community discussion seems to suggest that there isnt a way around this?), you basically cant really do conformational searching.
Funny enough i ran conformational searching in Avogadro 1.2 for some compounds like (a-bisabolol) and it worked fine but on Avogadro 1.9-2.0 with the openbabel option, it didnt work. Im trying to replicate results on a paper that did it on cocaine:
where they supposedly using avogadro. I’m not sure if there was an update on this issue but if avogadro 2.0 doesnt work with conformational search, im guessing there still isnt a way around this?
Open to any suggestions on how i can tackle this issue. Thanks

I think you have several questions that I’m going to separate out.

  1. How do you do a conformational search if Avogadro 1.2 (and Open Babel) don’t recognize a bond that you want to rotate?

You can only do that manually or with another package like RDKit. Open Babel and thus Avogadro 1.2 has a set of rules for which bonds to perform conformational search – to minimize the number of possible conformers.

  1. You want to perform a conformational search on α-(−)-Bisabolol that you ran in Avogadro 1.2, but does not seem to work in Avogadro 1.9x.

What version of Avogadro are you using? I hadn’t realized that older releases of Avogadro 1.9x didn’t have an Open Babel conformer search. It should be in the 1.99 release as well as nightly builds from

If I use the latest nightly, I can insert the molecule via SMILES and do a conformer search just fine:

  1. You want to be sure that conformer search options will be available in the eventual Avogadro 2.0 release.

Yes, absolutely. I have a National Science Foundation grant on efficient conformer search methods, and they will certainly find their way into Avogadro 2 (i.e., beyond the confab / Open Babel conformer methods in 1.2)

Beyond that, you can install the RDKit plugin and generate conformers with it. I’m also pretty sure other Python plugins will be built up for other conformer search methods (e.g., machine learning models, etc.)

Firstly, thanks for the reply. Secondly, i will be excited for future releases and improvements to avoogadro especially it being open-source :slight_smile: . I think i will like to divert my attention to another molecule since a-bisabolol isnt really the problem in my runs.

Bigger complex systems like ampilicin, when i loaded it up onto Avogadro 1.2, the program reads 0 rotatable bonds and thus does not run any conformational search basically. However, yesterday, i just ran it with confab in openbabel and it seems to recognise the rotatable bonds and confab did chunk out several conformers albeit, im not sure if there’s any ranking of conformers via energy. If not, im still finding a way around this.

^Also, you mention confab in 1.2 but im not sure i can access that option itself in 1.2 (?).

Edit: I just ran ampilicin with the nightly build 1.9-2.0 and still same issues with 1.2, 0 rotatable bond thus no conformational search. I was assuming that confab would be part of openbabel conformer running. Wait…, i just constructed the nightly build Avogadro 1.9-2.0 and tried to run conformer search on a-bisabolol and cant run it either ? Am i doing something wrong here…
minus_a_bisabolol.sdf (6.7 KB)
Ampicillin.sdf (6.4 KB)

*Attached the two files in case there issues with the particular model i am working with