Cmake can't find openbabel when compiling latest release

I’m trying to compile the latest release, and everything has gone
semi-smoothly up till now. I only had to manually enter a few of the
paths, the libgl file path (using AMD’s catalyst libgl) and the
qmake-qt4 path into the CMakeCache. I’m at a point where I’m not sure
what to enter into the CMakeCache internal entries. cmake is
complaining about not being able to find the openbabel libs. I’m
certain they are installed, and I can see them in
/usr/lib/openbabel/2.3.1 (I’m running debian testing if that helps).
The suspect section is here:

OPENBABEL2_CFLAGS:INTERNAL=
OPENBABEL2_CFLAGS_I:INTERNAL=
OPENBABEL2_CFLAGS_OTHER:INTERNAL=
OPENBABEL2_FOUND:INTERNAL=
OPENBABEL2_INCLUDEDIR:INTERNAL=
OPENBABEL2_LIBDIR:INTERNAL=
OPENBABEL2_LIBS:INTERNAL=
OPENBABEL2_LIBS_L:INTERNAL=
OPENBABEL2_LIBS_OTHER:INTERNAL=
OPENBABEL2_LIBS_PATHS:INTERNAL=
OPENBABEL2_PREFIX:INTERNAL=
OPENBABEL2_STATIC_CFLAGS:INTERNAL=
OPENBABEL2_STATIC_CFLAGS_I:INTERNAL=
OPENBABEL2_STATIC_CFLAGS_OTHER:INTERNAL=
OPENBABEL2_STATIC_LIBDIR:INTERNAL=
OPENBABEL2_STATIC_LIBS:INTERNAL=
OPENBABEL2_STATIC_LIBS_L:INTERNAL=
OPENBABEL2_STATIC_LIBS_OTHER:INTERNAL=
OPENBABEL2_STATIC_LIBS_PATHS:INTERNAL=
OPENBABEL2_VERSION:INTERNAL=
OPENBABEL2_openbabel-2.0_INCLUDEDIR:INTERNAL=
OPENBABEL2_openbabel-2.0_LIBDIR:INTERNAL=
OPENBABEL2_openbabel-2.0_PREFIX:INTERNAL=
OPENBABEL2_openbabel-2.0_VERSION:INTERNAL=

I’m sure that I need to point one of these to /usr/lib/ or
/usr/lib/openbabel, but I don’t want to botch the whole setup. I’ve
attached my current cache file too, incase it’s needed.

Thanks,

Kyle Bentley

Hi Kyle,

You shouldn’t need to modify the cache directly, especially not the
internal cache variables.

See http://avogadro.openmolecules.net/wiki/Compiling_on_Linux_and_Mac_OS_X
(It’s a bit confusing, there are two sections on building Avogadro on
that page for some reason). You want to set OPENBABEL2_INCLUDE_DIR to
something like $HOME/src/openbabel-2.2/include and
OPENBABEL2_LIBRARIES to something like
$HOME/src/openbabel-2.2/src/.libs/libopenbabel.so, depending on where
OB is installed.

Rather than editing the cache-file directly, try using cmake-gui
(requires Qt) or ccmake (terminal based, requires ncurses), depending
on if you’re at a terminal or not. Otherwise, you can just run:

cmake . -D=

in the build directory to adjust the settings.

Hope this helps,

Dave

On Tue, Jul 30, 2013 at 11:01 AM, Kyle Bentley kwbent@uab.edu wrote:

I’m trying to compile the latest release, and everything has gone
semi-smoothly up till now. I only had to manually enter a few of the paths,
the libgl file path (using AMD’s catalyst libgl) and the qmake-qt4 path into
the CMakeCache. I’m at a point where I’m not sure what to enter into the
CMakeCache internal entries. cmake is complaining about not being able to
find the openbabel libs. I’m certain they are installed, and I can see them
in /usr/lib/openbabel/2.3.1 (I’m running debian testing if that helps). The
suspect section is here:

OPENBABEL2_CFLAGS:INTERNAL=
OPENBABEL2_CFLAGS_I:INTERNAL=
OPENBABEL2_CFLAGS_OTHER:INTERNAL=
OPENBABEL2_FOUND:INTERNAL=
OPENBABEL2_INCLUDEDIR:INTERNAL=
OPENBABEL2_LIBDIR:INTERNAL=
OPENBABEL2_LIBS:INTERNAL=
OPENBABEL2_LIBS_L:INTERNAL=
OPENBABEL2_LIBS_OTHER:INTERNAL=
OPENBABEL2_LIBS_PATHS:INTERNAL=
OPENBABEL2_PREFIX:INTERNAL=
OPENBABEL2_STATIC_CFLAGS:INTERNAL=
OPENBABEL2_STATIC_CFLAGS_I:INTERNAL=
OPENBABEL2_STATIC_CFLAGS_OTHER:INTERNAL=
OPENBABEL2_STATIC_LIBDIR:INTERNAL=
OPENBABEL2_STATIC_LIBS:INTERNAL=
OPENBABEL2_STATIC_LIBS_L:INTERNAL=
OPENBABEL2_STATIC_LIBS_OTHER:INTERNAL=
OPENBABEL2_STATIC_LIBS_PATHS:INTERNAL=
OPENBABEL2_VERSION:INTERNAL=
OPENBABEL2_openbabel-2.0_INCLUDEDIR:INTERNAL=
OPENBABEL2_openbabel-2.0_LIBDIR:INTERNAL=
OPENBABEL2_openbabel-2.0_PREFIX:INTERNAL=
OPENBABEL2_openbabel-2.0_VERSION:INTERNAL=

I’m sure that I need to point one of these to /usr/lib/ or
/usr/lib/openbabel, but I don’t want to botch the whole setup. I’ve
attached my current cache file too, incase it’s needed.

Thanks,

Kyle Bentley


Get your SQL database under version control now!
Version control is standard for application code, but databases havent
caught up. So what steps can you take to put your SQL databases under
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711&iu=/4140/ostg.clktrk


Avogadro-Discuss mailing list
Avogadro-Discuss@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/avogadro-discuss

Dave,

Thanks for the advice. I hadn’t noticed that I’d forgotten the
openbabel dev files. Once I installed libopenbabel-dev and rebuilt the
cache everything was fine.

Kyle B

On 07/30/2013 10:15 AM, David Lonie wrote:

Hi Kyle,

You shouldn’t need to modify the cache directly, especially not the
internal cache variables.

See http://avogadro.openmolecules.net/wiki/Compiling_on_Linux_and_Mac_OS_X
(It’s a bit confusing, there are two sections on building Avogadro on
that page for some reason). You want to set OPENBABEL2_INCLUDE_DIR to
something like $HOME/src/openbabel-2.2/include and
OPENBABEL2_LIBRARIES to something like
$HOME/src/openbabel-2.2/src/.libs/libopenbabel.so, depending on where
OB is installed.

Rather than editing the cache-file directly, try using cmake-gui
(requires Qt) or ccmake (terminal based, requires ncurses), depending
on if you’re at a terminal or not. Otherwise, you can just run:

cmake . -D=

in the build directory to adjust the settings.

Hope this helps,

Dave

On Tue, Jul 30, 2013 at 11:01 AM, Kyle Bentleykwbent@uab.edu wrote:

I’m trying to compile the latest release, and everything has gone
semi-smoothly up till now. I only had to manually enter a few of the paths,
the libgl file path (using AMD’s catalyst libgl) and the qmake-qt4 path into
the CMakeCache. I’m at a point where I’m not sure what to enter into the
CMakeCache internal entries. cmake is complaining about not being able to
find the openbabel libs. I’m certain they are installed, and I can see them
in /usr/lib/openbabel/2.3.1 (I’m running debian testing if that helps). The
suspect section is here:

OPENBABEL2_CFLAGS:INTERNAL=
OPENBABEL2_CFLAGS_I:INTERNAL=
OPENBABEL2_CFLAGS_OTHER:INTERNAL=
OPENBABEL2_FOUND:INTERNAL=
OPENBABEL2_INCLUDEDIR:INTERNAL=
OPENBABEL2_LIBDIR:INTERNAL=
OPENBABEL2_LIBS:INTERNAL=
OPENBABEL2_LIBS_L:INTERNAL=
OPENBABEL2_LIBS_OTHER:INTERNAL=
OPENBABEL2_LIBS_PATHS:INTERNAL=
OPENBABEL2_PREFIX:INTERNAL=
OPENBABEL2_STATIC_CFLAGS:INTERNAL=
OPENBABEL2_STATIC_CFLAGS_I:INTERNAL=
OPENBABEL2_STATIC_CFLAGS_OTHER:INTERNAL=
OPENBABEL2_STATIC_LIBDIR:INTERNAL=
OPENBABEL2_STATIC_LIBS:INTERNAL=
OPENBABEL2_STATIC_LIBS_L:INTERNAL=
OPENBABEL2_STATIC_LIBS_OTHER:INTERNAL=
OPENBABEL2_STATIC_LIBS_PATHS:INTERNAL=
OPENBABEL2_VERSION:INTERNAL=
OPENBABEL2_openbabel-2.0_INCLUDEDIR:INTERNAL=
OPENBABEL2_openbabel-2.0_LIBDIR:INTERNAL=
OPENBABEL2_openbabel-2.0_PREFIX:INTERNAL=
OPENBABEL2_openbabel-2.0_VERSION:INTERNAL=

I’m sure that I need to point one of these to /usr/lib/ or
/usr/lib/openbabel, but I don’t want to botch the whole setup. I’ve
attached my current cache file too, incase it’s needed.

Thanks,

Kyle Bentley


Get your SQL database under version control now!
Version control is standard for application code, but databases havent
caught up. So what steps can you take to put your SQL databases under
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711&iu=/4140/ostg.clktrk


Avogadro-Discuss mailing list
Avogadro-Discuss@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/avogadro-discuss


Get your SQL database under version control now!
Version control is standard for application code, but databases havent
caught up. So what steps can you take to put your SQL databases under
version control? Why should you start doing it? Read more to find out.
http://pubads.g.doubleclick.net/gampad/clk?id=49501711&iu=/4140/ostg.clktrk


Avogadro-Discuss mailing list
Avogadro-Discuss@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/avogadro-discuss