Can't Open Gaussian Files in Avo2

Good Afternoon,

I recently got a new computer so I installed Avogadro2-1.970-win64 on it. I am using Avogadro-1.2.0n-win32 on both of my other PCs. This PC is running Windows 11x64bit.

When I go to import a Gaussian log file into Avogadro2, I am given three options: “Multiple readers found that can read this format. Which should be used?”

If I select Avogadro:GAMESS or Avogadro:NWChem I receive: “Error while reading file. Could not find any atomic coordinates!”

If I select OpenBabel: Generic Output file format I receive: “Error while reading file. OpenBabel error: conversion failed.”

I am just wondering what I can do to open my .log files from Gaussian 16 RevA.03?

I have also tried installing Avogadro2-1.95.0-win64 and that did not work either. When I tried installing Avogadro-1.2.0n-win32 I get the error “The code execution cannot proceed because MSVCP100.dll was not found. Reinstalling the program may fix this problem.”

Thank you!


Can you link the log file?

Playing around with this, I don’t think you can read Gaussian .log files with the GAMESS or NWchem interpreters, presumably because the outputs of those electronic structure codes are different from Gaussian. However, I was able to open a Gaussian 16 .log file in Avogadro 1.97.0

Another thing you might try is using the formchk utility in Gaussian to create an .fchk file and opening in Avo2 via the .fchk interpreter.

The issue is with all of my log files. And only on this fresh install of the new PC. This works on other versions on my other PCs. Just wondering how to fix this issue here, without first converting to formchk files.

Avogadro 1.97 doesn’t have code to read Gaussian output files by itself. By default, it should be handing that off to Open Babel to read. (Or if you have Python and cclib installed, you can use the avogadro-cclib extension to read through cclib.)

So the first step would be if you could post a link to one of your files … not sure why it’s not loading for you, but I’d like to debug the problem for 1.98.

I am facing the same problem. I have a Gaussian 16 log file that I cannot open with Avogadro 1.97.0. I get promoted for the readers and I get the same error with each of them as above. Could you please let me know whether you have found a fix or a work-around?

Can you share typical Gaussian 16 output (.log file) by a link, or as an attachment (compressed as .gz)? Second, try if openbabel (which accepts this as input/read-only format, reference) allows to extract the information you are interested.

As @Thomas mentioned, I would need an example file to find the bug. Otherwise, it’s hard to fix.

Hello @Thomas and @ghutchis, thank you for your response. I have attached an example Gaussian log file below.

@snayak Thank you for the share of the test file. Following a pattern I once met with molekel, I renamed the log file to carry a file extension which points to the version of Gaussian used; BENZE_opt.out hence became BENZE_opt.g16. There was no modification to the content of the file.

A test with openbabel (version 3.1.1) worked reasonably well:

$ obabel BENZE_opt.g16 -oxyz
BENZE_opt.g16	Energy: -145750.6127428
C          1.21134       -0.69949       -0.00000
C          1.21137        0.69931        0.00000
C          0.00010        1.39877        0.00000
C         -1.21135        0.69938        0.00000
C         -1.21142       -0.69932       -0.00000
C         -0.00000       -1.39872       -0.00000
H          2.15238       -1.24262       -0.00000
H          2.15228        1.24270        0.00000
H          0.00005        2.48526        0.00000
H         -2.15219        1.24284        0.00000
H         -2.15247       -1.24241       -0.00000
H         -0.00030       -2.48528       -0.00000
1 molecule converted

With the adjusted file extension, Avogadro2 (an AppImage for Linux fetched on 2023-06-15, running in LInux Debian 13/trixie) presents this visualization:

With reference to either x-, or y-coordinate of the first C atom in obabel’s output as .xyz above, there are two plausible spots in Gaussian’s report file from where the geometry was accessed – either the block lines 605 (and following), or lines 889 (and following):

$ grep "1.21134" BENZE_opt.g16 -n
605:      1          6           0        1.211344   -0.699491   -0.000000
889:      1          6           0        1.211344   -0.699491   -0.000000
$ grep "\-0.69949" BENZE_opt.g16 -n
605:      1          6           0        1.211344   -0.699491   -0.000000
889:      1          6           0        1.211344   -0.699491   -0.000000

@Thomas I will try renaming the file and see if that works, sometime soon. Thank you for the suggestion!

I missed your message and uninstalled Avogadro (current version) and installed an older version.
Avogadro 1.2.0, Open Babel 2.3.90, and Qt 4.8.6

I am able to open the Gaussian log files now and visualize the vibrations

@snayak Note for Avogadro 1.2.0, maintenance was dropped. If your workflow permits, use one of the executables of the contemporary branch instead (