Home   Manual

Cannot locate plug-in directory for Avogadro 2 in Windows


#1

I am having trouble locating the plug-in directory in Windows. I have checked the AppLocalDataLocation in Qt standard paths however none of the directories listed there were created during installation. I have tried creating them myself and adding an example plug-in (flattenZ.py) without any luck. Could anyone provide a working plug-in directory for Windows? Thanks!

I am using Avogadro 2 (1.91.0) installed using the Win64 installer on Windows 10.

Kutay


#2

Plugins are checked in subdirectories of the appLocalDataLocation based on script type. Here’s my example on Mac:

04%20PM

If you put it under workflows does it show up?

(BTW, the name will transition to commands instead of workflows soon - I just haven’t had time to finish the patch.)


#3

I have tried putting it under workflows directory however it still didn’t show up. It looks like there are 5 AppLocalDataLocation directories:

  • C:/Users/<USER>/AppData/Local/<APPNAME>
  • C:/ProgramData/<APPNAME>
  • <APPDIR>
  • <APPDIR>/data
  • <APPDIR>/data/<APPNAME>

Assuming <APPNAME> is Avogadro2 I placed the scripts as follow:

  • C:\Users\kutay\AppData\Local\Avogadro2\workflows
  • C:\ProgramData\Avogadro2\workflows

Neither of those directories existed so maybe I am getting the <APPNAME> wrong?


#4

APPNAME is Avogadro - but you can check on Windows fairly easily. If you start up Avogadro2 on a console, it will spit out a list of the directories it’s checking.


#5

I switched the Avogadro2 to Avogadro but I still cannot see the plug-in. I previously tried running the executable from the console hoping it would print the directories it’s searching (that’s how I found them in Linux) however it doesn’t print anything.