Building Openbabel in Mac OS 10.6.1

Bugs item #2890392, was opened at 2009-11-01 20:33
Message generated for change (Tracker Item Submitted) made by lricard
You can respond by visiting:

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Building / Install
Group: None
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Louis Ricard (lricard)
Assigned to: Nobody/Anonymous (nobody)
Summary: Building Openbabel in Mac OS 10.6.1

Initial Comment:
Hi All.

This certainly is not the list to post this, but.

I have not tried compiling Avo from sources for a while,
but since I migrated to Snow Leopard, I can no longer
compile OB and, hence, Avo, be it from older sources
or the latest svn (for OB).

The problem arises from the new default 64 bit option
in gcc 4.2. OB compiles and runs perfectly in 64 bit mode.
The problem is that QT won’t at the moment, so OB
must be compiled in 32 bit.

I tried “export CXXFLAGS=-m32” before configure and
sort of works, but some binaries are still "x86_84"
rather than “i386”.

Any clues ?

A file type list joined.


You can respond by visiting: