Home   Manual

Building Avogadro 1.2.0 fails on Scientific Linux 7 and CentOS 6: cannot find OpenBabel


#1

Hi,

Under CentOS 6 and Scientific Linux 7 I’ve been trying to build Avogadro, plus the two dependencies of it not provided by these distro’s repos: Eigen (specifically version 3.3.4)and OpenBabel (2.4.1). I built these dependencies without a problem and installed them to /home/fusion809/install/usr (-DCMAKE_INSTALL_PREFIX=/home/fusion809/install/usr). I have checked /home/fusion809/install/usr/include/openbabel-2.0/openbabel and the header files do exist there. The problem is now I’m trying to build Avogadro 1.2.0. I created a build directory called build inside the source directory of Avogadro 1.2.0, then I ran:

cmake .. -DCMAKE_INSTALL_PREFIX=/home/fusion809/install/usr

and I received the error:

-- Found Eigen3: /home/fusion809/install/usr/include/eigen3 (Required is at least version "2.91.0") 
-- Found ZLIB: /usr/lib64/libz.so (found version "1.2.7") 
-- Found PkgConfig: /bin/pkg-config (found version "0.27.1") 
-- checking for module 'openbabel-2.0>=2.3.0'
--   package 'openbabel-2.0>=2.3.0' not found
CMake Error at cmake/modules/FindOpenBabel2.cmake:69 (message):
  Could NOT find OpenBabel 2.3 or later
Call Stack (most recent call first):
  CMakeLists.txt:244 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/fusion809/Programs/avogadro-ot/avogadro-1.2.0/build/CMakeFiles/CMakeOutput.log".
See also "/home/fusion809/Programs/avogadro-ot/avogadro-1.2.0/build/CMakeFiles/CMakeError.log"

Then I thought maybe adding the option -DOPENBABEL2_INCLUDE_DIR=/home/fusion809/install/usr/include to the cmake command might fix things, after removing files generated by the first cmake run, of course, but it didn’t, I received the exact same error again. I then tried adding -DOPENBABEL2_INCLUDE_DIR=/home/fusion809/install/usr/include/openbabel-2.0 instead, but that gave me the exact same error. CMakeError.log is here and CMakeOutput.log is here.

Thanks for your time,
Brenton