Avogadro shuts down when trying to open ligand-receptor complex

Hello, my name is Florina, and I’m new in the molecular docking and molecular dynamics simulation world.
I’ve done molecular docking using CB Dock with my receptor and my ligand, and I downloaded the PDB files with the poses obtained to continue analyzing the best pose with a molecular dynamics simulation of the complex. To begin with this analysis, I need to make some changes to this complex with Avogadro. However, when I try to open the complex with Avogadro, it starts charging the complex, and a few seconds later, it automatically closes without showing any error message.
I’ve tried to uninstall the program and install it again, I also tried different versions (1.2, 1.95, and 1.99) or different complexes, but nothing worked. I’m working on a Windows 10 - 64 bits laptop, with an Intel Core i5-6200U CPU 2.30GHz, and I don’t know if it could be because of my laptop characteristics, or something else.
I would appreciate some feedback, as I want all these computational tools for some part of my PhD thesis.
Thank you in advance, and greetings.

Can you post a link to the file?

Certainly the 1.99 release or a nightly build from https://two.avogadro.cc should work. Not much we can do about fixing bugs in 1.2, but if you can share the file (either here or by DM) it would help considerably.

Thank you for your fast reply. I haven’t tried the nightly build form https://two.avogadro.cc/, but now I tried it and I opened Avogadro as an administrator and my molecule opened! Thank you again.