Avogadro doesn't open EDA .out files

I don’t know whether this is a bug with Avogadro or not.

I am using Avogadro 1.2.0 on Windows 11

It works fine except in one case, when I run an energy decomposition analysis (EDA) calculation on Chemcompute website. The .out files simply cannot be opened by Avogadro 1.2.0 which is very frustrating. I tried using Avogadro 2. It cannot open the file unless I open it from the software window, not through double-clicking. And even this option doesn’t always work.
Any help is much appreciated.

565956.out (66.7 KB)

Does the computer you use include in addition to Avogadro an installation of OpenBabel (project page, page to obtain an executable for either Windows, 32bit, or Windows, 64 bit)?

For an instance of Linux Debian 12/bookworm with OpenBabel and the AppImage of Avogadro 1.97 (the later downloaded on March 23 from this source), Avogadro reading your file starts with a question if the guessed format is correct


Since this indeed is good (match with the first couple of lines’ content), I proceed by “ok” to enter this display

1 Like

I don’t have OpenBabel installed on my computer, but I will try it.
Avogadro 2 can open EDA .out files when files are opened from the main window (i.e., not through double-clicking). My problem is that I use Avogadro 1.2.0 for many reasons, but it does not open the attatched file.
I will install Open Babel and inform you of updates.

Note: Avogadro 1.2 no longer is under active development for multiple years; however Windows might offer you a way to install “the old” Avogadro 1.2 side by side to Avogadro 1.97 (at some point Avogadro 2). Age shouldn’t be the sole / a dominant criterion to use a tool, or not; but if the tool reliably does the job it should do. (For some reason, I still retain e.g. a copy of Molekel.)

1 Like

More specifically, this looks like a GAMESS output file, so @Thomas advice is good. While I haven’t checked, I expect the GAMESS output format has changed since the version of Open Babel used in Avogadro v1.2.

Besides Open Babel, I also highly recommend https://cclib.github.io for parsing output files. For this reason, there’s an avgoadro-cclib extension that can be installed for Avogadro 2 which will allow files to be read through cclib if it’s installed on your computer.

1 Like

I’ve downloaded the latest version of Avogadro2 in addition to OpenBabel. Well! After some exploration it seems my problems are solved!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.