Avogadro 1.2 - can't pick an atom or make bonds

Environment Information

Avogadro version: 1.2.0
Operating system and version: windows 10 x64
Graphic card: AMD Radeon RX Vega 10

I have installed Avogadro 1.2.0 few weeks ago and everything was fine until one day i clicked an atom and dragged it to add another one, but nothing happend. Also when i click an atom it picks automaticly bond instead. I thought it might be my graphic card so i reinstalled drivers and it helped, but now it broke up again and reinstalling drivers doesnt help. I figured out that when I zoom out everything works ok, but it’s not comfortable that’s why i make this post. Does anyone know how to fix it? Is my graphic card too weak?

Ok i fixed this. It turns out the newest driver is the cause of this problem. If anyone else struggle with this - try installing old driver (for me worked one from 31.03.2022). :slight_smile:

If you have a chance, I’d be curious if the driver issue occurs with the Avo2 betas: https://two.avogadro.cc/

We rewrote the rendering code, so it should work much better with modern cards.

I checked this and Avogadro 2.0 works fine no matter which driver is installed :slight_smile:

Great to hear that you have a workaround for 1.2 and the problem is solved going forward with 2.0. Thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.