Avogadro 1.2.0 Can't Load the IR Frequencies Generated From ORCA 5.0.3

Environment Information

Avogadro version: 1.2.0
Operating system and version: Windows Version 10.0.19044.1706

Expected Behavior

I have just started using ORCA and was following a YouTube tutorial series by Dr. S. Kishor.

I’m using ORCA 5.0.3 on windows 10 with an i5 9400 processor and 500 GB A2000 Kingston RAM. In the 16th video of the series, I was introduced to IR frequencies calculation with geometry optimization with the input given at last.

The vibrational toolbar should open if I open the output file (.out) using Avogadro.

Actual Behavior

Now, when I’m opening the output file (.out) using Avogadro 1.2.0 (after installing the enhanced ORCA version), the molecule is loading, but the frequencies are not loading. I checked the output file(provided at last), and they were there but were not coming in Avogadro (should render automatically while opening the output file. I opened the Vibration toolbar from the settings of Avogadro to find they were not loaded. The screenshot of the Avogadro window with no loading of vibrational frequencies is given below -

Additional Action

I found a discussion in the ORCA forum about OfakeG, which can convert the ORCA output file into a Gaussian output file and I used that to covert as I have institutional access to Gaussian and GaussView. I followed the documentation but I was unable to convert the file type. I got an error saying the application couldn’t find the file.

Enclosed Files


Can anyone help me to view the IR frequencies generated from ORCA in Avogadro or other software?

Several people have noted that ORCA 5 has somehow changed the output format of vibrations from ORCA 4.

I posted in the Orca forum myself … and a developer replied, but has otherwise not engaged.

I don’t think we’ll be able to get a solution for Avogadro 1.2.x because we are unable to compile any of the components (e.g., it uses Qt 4.x which was last released in 2015 and is no longer supported).

On the other hand, we are working to finish up Avogadro 2, which would naturally support ORCA 5. (It’s what we use in my research group right now.)

1 Like

One workaround would be to try Jmol / Jsmol - Bob Hansen is often able to quickly support changes in file formats. (Usually we are as well - I only found out about the change in ORCA 5 vibrations a few weeks ago.)

1 Like

Does the available Avogadro2-1.91.0-win64.exe support ORCA 5? Then I’ll try out that.

Though I downgraded to ORCA 4.1 with enhanced Avogadro for ORCA 4.1 (suggested to use in this discussion), No vibrational displacements exist error message is popping up when I’m clicking Start Animation or any specific vibrational frequency.

If nothing works, I have to look at Jmol / Jsmol as suggested by you.

Many, many thanks for such quick support.

Best Regards,

First off, that’s a really old version. Try 1.96:

I’ve had the most luck with using Avogadro2 with the Python / cclib extension. Install cclib into your Python environment, e.g.
pip3 install cclib or conda install cclib

Then you can use Extensions => Download Plugins… and select the avogadro-cclib extension to read output files through cclib which does support ORCA5.

Personally, I’m surprised that the “enhanced” version of Avogadro provided by the Orca developers doesn’t read their own files. We had a great collaboration through Orca 4.2… hopefully we can resume soon.

1 Like

Thanks, Geoff. I’ll try using cclib and let you know.

To be double sure, I have tried several times with the enhanced version (both beta versions supporting 4.2 and stable 4.1), as described in another discussion. So also, I deleted the post first and tried one more time to be entirely sure of the problem. I don’t know if the error is coming only for my system (though I guess not).

There’s been several comments about the vibrations (in particular) changing in ORCA 5.

We’ll get it fixed for the next release.

1 Like

@ghutchis, if you don’t mind can you help in this case?

After going to Extensions => Download Plugins no packages are coming to select. I have installed Avogadro2-1.96.0-win64.exe

Btw, I have succeeded to use OfakeG. Though they said I can run the .exe and drag the .out file to the application window, always the application can’t find the file. But this time I kept the .out file in the same folder and ran OfakeG from terminal (cmd) to get the converted Gaussian output.