Reading molecular file failed - Cannot open any file

I have installed AvogadroOrca4.1.exe to visualize the ORCA output files.
However, I cannot open any file with this software.

Once I tried to open any file (.xyz, .inp, or .out), an error message popped up; Reading molecular file failed, file PATH.format.
I also tried other versions including 1.1.0, 1.2.0, and 1.91.0. But all showed the same error message and failed to open any files.

Is there anybody who resolved this issue? Am I missing any step to activate Avogadro?
I am using Windows 10 x64.
Please let me know how to properly set up Avogadro.

Thank you.

I’m having the same issue.
I can open old orca .out files (Orca and a couple of new ones (Orca 4.1.1). The only meaning full difference I see between the files I can and the ones I can’t open are the vibrational freq. calculations. The .out files with freq. calculations do not open.
I’m providing a link with two examples, the one I can open (without-freq.out) and the one I can’t (with-freq.out).

Finally, I would like to thank the Avogadro team for their work!

Thank you for sharing.
I have same bug. I tried your two examples and find same thing. However, my .out file does not have freq. and I can’t open it.
I am a freshman in Quantum Chemistry and it makes me confused.
I am using ORCA 4.1.0, Windows, 64bit and Avogadro (ORCA enhanced version).
Thank you.

I’m also having this problem. I’ve tried reinstalling Avogadro and OpenBabel, but to no avail.

Operating system: Ubuntu 19.10.
Avogadro version: 1.2.0
OpenBabel version: 2.4.1

I just was able to circumvent a similar issue and wanted to share the workaround.
In my case a Windows Avogadro could open ORCA output files generated on my Mac but not on the Windows system itself. It turned out that the issue was that ORCA was not writing the output file in nice plain ASCII text. Using the Windows PowerShell, one can convert the ORCA output file to ASCII text like so:
gc hexatriene_geom.opt | out-file –encoding ASCII hexatriene_geom_ascii.out
Avogadro could open the resulting file and display the molecular orbitals as desired.


I’ve tried that on Ubuntu and the error is gone but there is another problem: no atom is displayed although they are there. However, I think this is unrelated.
But how weird, why do I suddenly have to convert Gaussian output while it worked just fine before?

Hi all,
Very similar situation here while I see that no real solution was provided.

I have installed AvogadroOrca4.1.exe to create chemical structures and generate Orca’s input files. Once I created the .input file I cannot open it again with Avogadro and I get the error:
Reading molecular file failed, file PATH.format.

I tried saving as other input files (.com,.xyz) and the exact same error is showing up. The only format I can open is .cml. I also try with the latest Avogadro and I get the same issue.

Is there anybody who resolved this issue? I have seen somewhere people talking about openbabel could be missing, any clue if that is the reason? and if yes how can I solved it (installing openbabel did not work)

I am using Windows 10 x64.

@csnow’s solution worked for me.

I downloaded both files and checked their encodings and sure enough the one with frequency is UTF-16 and the one without frequency is UTF-8 (ASCII), so, as @csnow suggested, it looks like it all boils down to whether the file is encoded in ASCII.

Running the line below in command prompt produced the same file except in ASCII so it could be read by Avogadro. I tried importing it to Avogadro and it worked.

gc with-freq.out | out-file -encoding ASCII with-freq_ascii.out

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.