Menu is too long for 1024 resolution

Hi,

Avogadro is my favorit software for my chemistry lessons.
I often use with a video projector. Therefore i have 1024 resolution. The menu at the top of the screen is not visible completely. Please collect menuitems together for a shorter menu. In the german package there are TWO “Erweiterungen” items… :frowning: why?

Thanks for your fantastic work and keep on…
best regards
M. Woski


Karlsgymnasium Bad Reichenhall
Dr. rer. nat. M. Woski
Chemie/biologie
Salzburgerstr. 28
83435 Bad Reichenhall
Germany

Avogadro is my favorit software for my chemistry lessons.

Thanks!

I often use with a video projector. Therefore i have 1024 resolution. The menu at the top of the screen is not visible completely. Please collect menuitems together for a shorter menu. In the german package there are TWO “Erweiterungen” items… :frowning: why?

Can you tell us what version of Avogadro you are using? Also, can you give us a screenshot or list of the items in the Erweiterungen menus?

Thanks very much,
-Geoff

From your screenshot, you’re clearly using a Mac. (I guessed from your e-mail address, but wanted to be sure.)

I’m surprised you have duplicate menus and will investigate that bug. If you wish to force the Mac version to use English, here are two solutions:

  1. In System Preferences, under “International” or “Language and Text”, make sure “English” is listed as the top, preferred language. Avogadro uses this to determine the translation to use.

  2. In the Finder, go to Avogadro.app, right click and choose “Show Package Contents”. Navigate to Contents > share > avogadro > i18n. Delete the file avogadro_de.qm. This is the German translation.

Hope that helps,
-Geoff

i will try to find a solution:
I use version 1.00 german

the menu bar shows
File (german: Datei)
Edit (german: Bearbeiten)
view (german: Ansicht)
Built (german: Erstelen)
Select (german: Auswahl)
Extensions (german: Erweiterungen)
Erweiterungen (engl: extensions)
Datei (engl. file)
Struktur (engl. structure seems to bee “built”)
Ansicht (engl view)
Auswahl (engl. select)
Window
Help

From your screenshot, you’re clearly using a Mac. (I guessed from your e-mail address, but wanted to be sure.)
I’m surprised you have duplicate menus and will investigate that bug. If you wish to force the Mac version to use English, here are two solutions:

  1. In System Preferences, under “International” or “Language and Text”, make sure “English” is listed as the top, preferred language. Avogadro uses this to determine the translation to use.
  2. In the Finder, go to Avogadro.app, right click and choose “Show Package Contents”. Navigate to Contents > share > avogadro > i18n. Delete the file avogadro_de.qm. This is the German translation.

I think it would be a good feature to change language “on the fly” from Setting dialog. The only problem I see is how to get a list of available translations

Hope that helps,
-Geoff

i will try to find a solution:
I use version 1.00 german

the menu bar shows
File (german: Datei)
Edit (german: Bearbeiten)
view (german: Ansicht)
Built (german: Erstelen)
Select (german: Auswahl)
Extensions (german: Erweiterungen)
Erweiterungen (engl: extensions)
Datei (engl. file)
Struktur (engl. structure seems to bee “built”)
Ansicht (engl view)
Auswahl (engl. select)
Window
Help


Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what’s new with
Crystal Reports now. http://p.sf.net/sfu/bobj-july


Avogadro-devel mailing list
Avogadro-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/avogadro-devel


Regards,
Konstantin

Яндекс.Почта. Письма есть. Спама - нет. http://mail.yandex.ru/nospam/sign

Thans for your answer,

but when I chance Language/Text in system settings the menu in the complete OS is changed… :frowning:
regards
M. Woski

Am 29.11.2009 um 14:31 schrieb Konstantin Tokarev:

From your screenshot, you’re clearly using a Mac. (I guessed from your e-mail address, but wanted to be sure.)
I’m surprised you have duplicate menus and will investigate that bug. If you wish to force the Mac version to use English, here are two solutions:

  1. In System Preferences, under “International” or “Language and Text”, make sure “English” is listed as the top, preferred language. Avogadro uses this to determine the translation to use.
  2. In the Finder, go to Avogadro.app, right click and choose “Show Package Contents”. Navigate to Contents > share > avogadro > i18n. Delete the file avogadro_de.qm. This is the German translation.

I think it would be a good feature to change language “on the fly” from Setting dialog. The only problem I see is how to get a list of available translations

Hope that helps,
-Geoff

i will try to find a solution:
I use version 1.00 german

the menu bar shows
File (german: Datei)
Edit (german: Bearbeiten)
view (german: Ansicht)
Built (german: Erstelen)
Select (german: Auswahl)
Extensions (german: Erweiterungen)
Erweiterungen (engl: extensions)
Datei (engl. file)
Struktur (engl. structure seems to bee “built”)
Ansicht (engl view)
Auswahl (engl. select)
Window
Help


Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what’s new with
Crystal Reports now. http://p.sf.net/sfu/bobj-july


Avogadro-devel mailing list
Avogadro-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/avogadro-devel


Regards,
Konstantin

Яндекс.Почта. Письма есть. Спама - нет. http://mail.yandex.ru/nospam/sign

but when I chance Language/Text in system settings the menu in the complete OS is changed… :frowning:

OK, then try #2

  1. In the Finder, go to Avogadro.app, right click and choose “Show Package Contents”. Navigate to Contents > share > avogadro > i18n. Delete the file avogadro_de.qm. This is the German translation.

Best regards,
-Geoff