Help to run Avogadro 0.9.0

Hello,
I’m David. I’m working at University of Vigo in Spain.
Here we’ve an SGI Altix450 machine (Itanium processors).
OS: SUSE Enterprise Server 10.
We’ve installed Cmake 2.6.2, Openbabel 2.2.0, Eigen 2.0 beta6 and Qt 4.4.3
first and then we’ve installed Avogadro 0.9.0 without problems.
But when we try to launch it doesn’t work and exit the next message:
david@galvatron:~> avogadro
avogadro: error while loading shared libraries: libavogadro.so.0: cannot
open shared object file: No such file or directory
david@galvatron:~>
Can you help me??
Thanks a lot
Best Regards

  •     --DAVID--*

You have to specify the library path if not already in the dynamic
linker path
Faster solution is to write a script like

#!/bin/bash
export LD_LIBRARY_PATH=where_libavogadro_is:$LD_LIBRARY_PATH
avogadro

Hello,
I’m David. I’m working at University of Vigo in Spain.
Here we’ve an SGI Altix450 machine (Itanium processors).
OS: SUSE Enterprise Server 10.
We’ve installed Cmake 2.6.2, Openbabel 2.2.0, Eigen 2.0 beta6 and Qt
4.4.3 first and then we’ve installed Avogadro 0.9.0 without problems.
But when we try to launch it doesn’t work and exit the next message:
david@galvatron:~> avogadro
avogadro: error while loading shared libraries: libavogadro.so.0:
cannot open shared object file: No such file or directory
david@galvatron:~>
Can you help me??
Thanks a lot
Best Regards

/* --DAVID–*/


This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword


Avogadro-devel mailing list
Avogadro-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/avogadro-devel

I’ve been trying to get Avogadro running on my Mac, but the past few
revisions I’ve tried all crash shortly after loading the software.
After opening the app, the window appears and I’m stuck with a
spinning beach ball for a few seconds, followed by a crash. Running
the application on the command line gives me:

Avogadro version: 0.9.2
LibAvogadro version: “0.9.2"
Locale: “en_US"
path = “/Applications/Avogadro.app/Contents/MacOS/…/share/avogadro/
i18n/”
”/Applications/Avogadro.app/Contents/MacOS/…/share/avogadro/i18n/
avogadro_en_US.qm” not found.
path = “/usr/local/share/avogadro/i18n/”
"/usr/local/share/avogadro/i18n/avogadro_en_US.qm" not found.
“System has OpenGL support.”
“About to test OpenGL capabilities.”
"OpenGL capabilities found: "
“Double Buffering.”
“Direct Rendering.”
"Antialiasing."
Searching for plugins in "/Applications/Avogadro.app/Contents/
MacOS/…/lib/avogadro/colors"
Searching for plugins in "/Applications/Avogadro.app/Contents/
MacOS/…/lib/avogadro/engines"
Searching for plugins in "/Applications/Avogadro.app/Contents/
MacOS/…/lib/avogadro/extensions"
Searching for plugins in "/Applications/Avogadro.app/Contents/
MacOS/…/lib/avogadro/tools"
Searching for plugins in "/usr/local/lib/avogadro/colors"
Searching for plugins in "/usr/local/lib/avogadro/engines"
Searching for plugins in "/usr/local/lib/avogadro/extensions"
Searching for plugins in "/usr/local/lib/avogadro/tools"
Unversioned configuration - clearing.
GLWidget initialisation…
GLWidget initialised…
createObjects()
Segmentation fault

I ran gdb on the app to see if I could get any more information. The
entire output is pasted at http://pastebin.ca/1358242. The details of
the crash are:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0xbf7fffec
0x905bcc2c in szone_size ()

I’m not sure if this is an issue with my system or a bug in Avogadro.
Please let me know if there’s anything I can try to get Avogadro
running.

Thank you,
Jayson Kempinger


This message is digitally signed with GnuPG:
http://www.kempinger.us/gpg.php?eid=3

Jayson Kempinger wrote:

I’ve been trying to get Avogadro running on my Mac, but the past few
revisions I’ve tried all crash shortly after loading the software.
After opening the app, the window appears and I’m stuck with a
spinning beach ball for a few seconds, followed by a crash. Running
the application on the command line gives me:

I ran gdb on the app to see if I could get any more information. The
entire output is pasted at http://pastebin.ca/1358242. The details of
the crash are:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0xbf7fffec
0x905bcc2c in szone_size ()

I’m not sure if this is an issue with my system or a bug in Avogadro.
Please let me know if there’s anything I can try to get Avogadro running.

From the output you pasted I cannot see anything. If you could paste a
backtrace that would help much more. When you get to the same point with
the memory access issue just type bt (short for backtrace) and press
enter. If you paste the output from that then it should help narrow down
what function Avogadro is crashing inside of.

Thanks,

Marcus

A backtrace shows this:

#0 0x95e4b3ac in _CFRuntimeCreateInstance ()
#1 0x95dd93c8 in __CFArrayInit ()
#2 0x929f0b2b in HIObject::GetNamedAccessibleAttributeSelf ()
#3 0x92b220be in HIView::GetNamedAccessibleAttributeSelf ()
#4 0x929f0172 in HIObject::DispatchAccessibilityEvent ()
#5 0x929efe44 in HIObject::HandleClassAccessibilityEvent ()
#6 0x9296d63c in HIObject::EventHook ()
#7 0x9296d143 in DispatchEventToHandlers ()
#8 0x9296c57d in SendEventToEventTargetInternal ()
#9 0x929de515 in CallNextEventHandler ()
#10 0x00eae3ad in getNamedAttribute ()
#11 0x00eb0a95 in accessibilityEventHandler ()
#12 0x9296d143 in DispatchEventToHandlers ()
#13 0x9296c57d in SendEventToEventTargetInternal ()
#14 0x9296c3e2 in SendEventToEventTargetWithOptions ()
#15 0x92b03808 in Accessible::SendEvent ()
#16 0x92b04a5e in Accessible::GetNamedAttributeData ()
#17 0x92b04557 in GetEventParameterAsPropertyList ()

#80588 0x92b04a88 in Accessible::GetNamedAttributeData ()
#80589 0x92b04557 in GetEventParameterAsPropertyList ()
#80590 0x92b0495b in Accessible::GetNamedAttributeDataCount ()
#80591 0x92b0535f in CarbonGetAttributeValueCountCallback ()
#80592 0x925eb196 in _AXXMIGGetAttributeValueCount ()
#80593 0x925f1fc6 in _XGetAttributeValueCount ()
#80594 0x925bb4d8 in mshMIGPerform ()
#80595 0x95e498e8 in CFRunLoopRunSpecific ()
#80596 0x95e49cd8 in CFRunLoopRunInMode ()
#80597 0x00a2eb20 in QEventDispatcherMac::processEvents ()
#80598 0x005db2c1 in QEventLoop::processEvents ()
#80599 0x005db38d in QEventLoop::exec ()
#80600 0x005df331 in QCoreApplication::exec ()
#80601 0x000126b8 in main ()

The plist events #16 & 17 repeat from lines 16 until 80,589. I
suspect the issue may be with a corrupted property list file, but I’m
not sure where Avogadro stores its plist files. I can’t find anything
in ~/Library/Preferences or ~/Library/Application\ Support.

~Jayson


This message is digitally signed with GnuPG:
http://www.kempinger.us/gpg.php?eid=3

On Mar 11, 2009, at 11:03 AM, Marcus D. Hanwell wrote:

Jayson Kempinger wrote:

I’ve been trying to get Avogadro running on my Mac, but the past few
revisions I’ve tried all crash shortly after loading the software.
After opening the app, the window appears and I’m stuck with a
spinning beach ball for a few seconds, followed by a crash. Running
the application on the command line gives me:

I ran gdb on the app to see if I could get any more information. The
entire output is pasted at http://pastebin.ca/1358242. The details
of
the crash are:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0xbf7fffec
0x905bcc2c in szone_size ()

I’m not sure if this is an issue with my system or a bug in Avogadro.
Please let me know if there’s anything I can try to get Avogadro
running.

From the output you pasted I cannot see anything. If you could paste a
backtrace that would help much more. When you get to the same point
with
the memory access issue just type bt (short for backtrace) and press
enter. If you paste the output from that then it should help narrow
down
what function Avogadro is crashing inside of.

Thanks,

Marcus

The plist events #16 & 17 repeat from lines 16 until 80,589. I
suspect the issue may be with a corrupted property list file, but
I’m not sure where Avogadro stores its plist files. I can’t find
anything in ~/Library/Preferences or ~/Library/Application\ Support.

It’s ~/Library/Preferences/net.sourceforge.Avogadro.plist.

Hope that helps,
-Geoff

It looks like it’s not a corrupted plist file then. That file doesn’t
exist on my system. I tried touching a blank file and running
Avogadro, but it still crashes. Deleted the blank file and ran again,
but still crashes.

~Jayson


This message is digitally signed with GnuPG:
http://www.kempinger.us/gpg.php?eid=3

On Mar 11, 2009, at 11:54 AM, Geoffrey Hutchison wrote:

The plist events #16 & 17 repeat from lines 16 until 80,589. I
suspect the issue may be with a corrupted property list file, but
I’m not sure where Avogadro stores its plist files. I can’t find
anything in ~/Library/Preferences or ~/Library/Application\ Support.

It’s ~/Library/Preferences/net.sourceforge.Avogadro.plist.

Hope that helps,
-Geoff