Bug in the multithreading code

Moin

I just did a clean (!) build (after rm -r $BUILDDIR) of the current
svn (post multithreading branch). Now, Avo refuses to start. On the
shell there is no output, the app isn’t comming up either. I used
strace to see where it hangs and the last issued line is about a
futex:

stat64("/usr/lib/qt4/plugins/inputmethods/libqimsw-multi.so",
{st_mode=S_IFREG|0755, st_size=27444, …}) = 0
getcwd("/home/kde4/build/avo", 4096) = 21
lstat64("/usr", {st_mode=S_IFDIR|0755, st_size=4096, …}) = 0
lstat64("/usr/lib", {st_mode=S_IFDIR|0755, st_size=106496, …}) = 0
lstat64("/usr/lib/qt4", {st_mode=S_IFDIR|0755, st_size=4096, …}) = 0
lstat64("/usr/lib/qt4/plugins", {st_mode=S_IFDIR|0755, st_size=4096, …}) = 0
lstat64("/usr/lib/qt4/plugins/inputmethods", {st_mode=S_IFDIR|0755,
st_size=4096, …}) = 0
lstat64("/usr/lib/qt4/plugins/inputmethods/libqimsw-multi.so",
{st_mode=S_IFREG|0755, st_size=27444, …}) = 0
chdir("/home/kde4/build/avo") = 0
stat64("/usr/lib/qt4/plugins/inputmethods/libqimsw-multi.so",
{st_mode=S_IFREG|0755, st_size=27444, …}) = 0
stat64("/usr/lib/qt4/plugins/inputmethods/libqimsw-multi.so",
{st_mode=S_IFREG|0755, st_size=27444, …}) = 0
stat64("/home/kde4/.config/Trolltech.conf", {st_mode=S_IFREG|0600,
st_size=27856, …}) = 0
open("/home/kde4/.config/Trolltech.conf", O_RDONLY|O_LARGEFILE) = 8
close(8) = 0
stat64("/home/kde4/.config/Trolltech.conf", {st_mode=S_IFREG|0600,
st_size=27856, …}) = 0
stat64("/home/kde4/.config/Trolltech.conf", {st_mode=S_IFREG|0600,
st_size=27856, …}) = 0
stat64("/etc/settings/Trolltech.conf", 0xbff15a70) = -1 ENOENT (No
such file or directory)
stat64("/etc/settings/Trolltech.conf", 0x80e3878) = -1 ENOENT (No such
file or directory)
stat64("/home/kde4/build/avo/avogadro/src/inputmethods/.", 0x80e3740)
= -1 ENOENT (No such file or directory)
lstat64("/home/kde4/build/avo/avogadro/src/inputmethods/.",
0xbff15e50) = -1 ENOENT (No such file or directory)
stat64("/home/kde4/kde/lib/kde4/plugins/inputmethods/.", 0x80e3740) =
-1 ENOENT (No such file or directory)
lstat64("/home/kde4/kde/lib/kde4/plugins/inputmethods/.", 0xbff15e50)
= -1 ENOENT (No such file or directory)
write(7, “\24\0\6\0D\0\0\0\27\0\0\0\0\0\0\0\0\0\0\0\0 \0\0”, 24) = 24
read(7, “\1\10z\0G\20\0\0\37\0\0\0\0\0\0\0\33A\0\0\0\0\0\0\0\0\0”…, 32) = 32
readv(7, [{"*AxeText.Translations:\t#override"…, 16667}, {"\0", 1}],
2) = 16668
writev(7, [{“b\0\6\0\17\0\0\0”, 8}, {“XInputExtension”, 15}, {"\0", 1}], 3) = 24
read(7, “\1\322{\0\0\0\0\0\1\221_\250\0\20\0\0\0\0\0\0\0\0\0\0\0”…, 32) = 32
futex(0x80cb468, FUTEX_WAIT, 2, NULL

I thought I’d ping the mailinglist first before reporting a bug.

Carsten

Moin

For the record: I just reported this as issue 1760151:

http://sourceforge.net/tracker/index.php?func=detail&aid=1760151&group_id=165310&atid=835077

Carsten