Home   Manual

Avogadro crashes or becomes unresponsive when trying to build a surface using the "Slab" command

I believe this to be a bug with Avogadro

Environment Information

Avogadro version: 1.2.0
Operating system and version: Windows 10

Expected Behavior

Hi,
I’m a new, unexperienced Avogadro user and I’ve run into a problem I can’t yet figure out a solution for.

I wanted to build an extended periclase-type surface where some of the Mg atoms are substituted by Fe atoms (MgFeO). Therefore, I first loaded the MgO crystal structure from Avogadro’s own library, then I substituted one Mg atom manually and then tried to build an extended surface using the “slab” command.

Actual Behavior

Irrespective of the Miller indices, the surface size or the type of surface I try to generate, the button “Build” turns to “Working” after pressing it, but the program first becomes unresponsive and then either crashes or stays unresponsive for a very long period of time (without actually generating the surface).

Steps to Reproduce

File > Import > Crystal > type in “periclase” > select “MgO-periclase.cif” > insert > substitute one Mg atom with a Fe one using the “Draw” tool > Crystallography > Build > Slab > select Miller indices (I tried with 0,0,1 and then 1,0,0) > x = 10 A, y = 10 A, z = 40A > Build

Any kind of suggestion on how I can overcome this problem would be greatly appreciated!
Thank you,
Tudor

The way Avo1 builds slabs is really, really inefficient. It generates an appropriate supercell and cuts it down to size. I doubt it’s crashed, but it’s definitely taken a long time to generate for me.

My suggestion for building slabs is 100% to use pymatgen - it’s much more efficient.
https://workshop.materialsproject.org/lessons/03_surfaces/Working%20With%20Surfaces_lesson/

The docs include some citations:
https://pymatgen.org/pymatgen.core.surface.html