Avogadro 1.0.0 packages for Debian/Ubuntu

That would be a real shame. Also, I note that I wasn’t able
to compile Avogadro with the packages available in Ubuntu 9.04 (the
current release) which is also a shame (it misses out on the required
Qt by 0.02).

Is there a specific reason for requiring Qt-4.5.3 on the Debichem
pacakges of Avogadro-1.0? While I know there are bug-fixes in
Qt-4.5.3, and it’s certainly recommended, I think Noel raises a good
point.

The source release just requires Qt-4.5.0 or later.

Thanks,
-Geoff

2009/10/29 Geoffrey Hutchison geoff.hutchison@gmail.com:

That would be a real shame. Also, I note that I wasn’t able
to compile Avogadro with the packages available in Ubuntu 9.04 (the
current release) which is also a shame (it misses out on the required
Qt by 0.02).

Is there a specific reason for requiring Qt-4.5.3 on the Debichem pacakges
of Avogadro-1.0? While I know there are bug-fixes in Qt-4.5.3, and it’s
certainly recommended, I think Noel raises a good point.

The source release just requires Qt-4.5.0 or later.

The problem I was referring to was that the source requires 4.5.2, but
only 4.5.0 was available (as part of the package management system).
The issue you are referring to is slightly different (and Debian must
ship with Qt 4.5.3 or otherwise they wouldn’t be allowed to include
Avogadro).

  • Noel

On Oct 29, 2009, at 8:12 AM, Noel O’Boyle wrote:

The problem I was referring to was that the source requires 4.5.2, but
only 4.5.0 was available

Where does the source require 4.5.2?

set(QT_MIN_VERSION “4.5.0”) # we need at least version 4.3 of Qt now

Well, ignore the comment. Grepping for QT_MIN_VERSION, I don’t see
anything else.

-Geoff

2009/10/29 Geoffrey Hutchison geoff.hutchison@gmail.com:

On Oct 29, 2009, at 8:12 AM, Noel O’Boyle wrote:

The problem I was referring to was that the source requires 4.5.2, but
only 4.5.0 was available

Where does the source require 4.5.2?

The INSTALL file says 4.5.2. Which is right?

set(QT_MIN_VERSION “4.5.0”) # we need at least version 4.3 of Qt now

Well, ignore the comment. Grepping for QT_MIN_VERSION, I don’t see anything
else.

-Geoff

That would be a real shame. Also, I note that I wasn’t able
to compile Avogadro with the packages available in Ubuntu 9.04 (the
current release) which is also a shame (it misses out on the required
Qt by 0.02).

Shame on Ubuntu, because in Debian you can gracefully install packages from testing or unstable branches, keeping Debian stable

If you want to do the same thing on Ubuntu, change your version name in /etc/apt/sources.list to name of next (unstable) version (e.g. to karmic), and install all you need, than you are free to change it back

The problem I was referring to was that the source requires 4.5.2, but
only 4.5.0 was available (as part of the package management system).
The issue you are referring to is slightly different (and Debian must
ship with Qt 4.5.3 or otherwise they wouldn’t be allowed to include

Avogadro builds, but works incorrectly with 4.5.0, e.g. selections don’t work

Regards,
Konstantin

29.10.09, 12:12, “Noel O’Boyle” baoilleach@gmail.com:

2009/10/29 Geoffrey Hutchison :

That would be a real shame. Also, I note that I wasn’t able
to compile Avogadro with the packages available in Ubuntu 9.04 (the
current release) which is also a shame (it misses out on the required
Qt by 0.02).

Is there a specific reason for requiring Qt-4.5.3 on the Debichem pacakges
of Avogadro-1.0? While I know there are bug-fixes in Qt-4.5.3, and it’s
certainly recommended, I think Noel raises a good point.

The source release just requires Qt-4.5.0 or later.
The problem I was referring to was that the source requires 4.5.2, but
only 4.5.0 was available (as part of the package management system).
The issue you are referring to is slightly different (and Debian must
ship with Qt 4.5.3 or otherwise they wouldn’t be allowed to include
Avogadro).

  • Noel

Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9 - 12, 2009. Register now!
http://p.sf.net/sfu/devconference


Avogadro-devel mailing list
Avogadro-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/avogadro-devel


Regards,
Konstantin

Почта вам с кисточкой: http://mail.yandex.ru/promo/new/paint

On Thu, Oct 29, 2009 at 08:01:18AM -0400, Geoffrey Hutchison wrote:

That would be a real shame.

Just wondering, what would be a shame? I think I missed the beginning
of the conversation.

Also, I note that I wasn’t able to compile Avogadro with the
packages available in Ubuntu 9.04 (the current release) which is
also a shame (it misses out on the required Qt by 0.02).

Is there a specific reason for requiring Qt-4.5.3 on the Debichem
pacakges of Avogadro-1.0? While I know there are bug-fixes in
Qt-4.5.3, and it’s certainly recommended, I think Noel raises a good
point.

The source release just requires Qt-4.5.0 or later.

For compilation, the Debian package requires version 4.4.0 of libqt4-dev
currently, I forgot to bump the requirements.

As for runtime requirements, the avogadro package requires (>= 4:4.5.3)
(ignore the 4:), because the dynamic linking dependency resolver got
told by the Qt packages it should write 4.5.3 there, I don’t know the
rationale for that, but I guess the Debian Qt maintainer just want to be
safe than sorry and don’t relax the run-time linking requirements.

Michael

The INSTALL file says 4.5.2. Which is right?

I think the most recent version of Qt is probably best – there are
substantial bug fixes in 4.5.2 and 4.5.3.

But I’ll go revise the INSTALL file – only 4.5 is required, but
more recent versions are recommended (as Konstantin indicated).

Cheers,
-Geoff

2009/10/29 Geoffrey Hutchison geoff.hutchison@gmail.com:

The INSTALL file says 4.5.2. Which is right?

I think the most recent version of Qt is probably best – there are
substantial bug fixes in 4.5.2 and 4.5.3.

But I’ll go revise the INSTALL file – only 4.5 is required, but more
recent versions are recommended (as Konstantin indicated).

In that case, change my initial comment to “It’s great that Avogadro
can be compiled with packages available in the latest Ubuntu release.
Keep it up!” :slight_smile:

Cheers,
-Geoff